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Safety Guidelines

This manual contains notices intended to ensure personal safety, as well as to protect the products and
connected equipment against damage. These notices are highlighted by the symbols shown below and

graded according to severity by the following texts:

Danger

precautions are not taken.

indicates that death, severe personal injury or substantial property damage will result if proper

Warning

precautions are not taken.

indicates that death, severe personal injury or substantial property damage can result if proper

Caution

> B P

indicates that minor personal injury can result if proper precautions are not taken.

Caution

indicates that property damage can result if proper precautions are not taken.

Notice

draws your attention to particularly important information on the product, handling the product, or to a

particular part of the documentation.

Qualified Personnel

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons are
defined as persons who are authorized to commission, to ground and to tag circuits, equipment, and
systems in accordance with established safety practices and standards.

Correct Usage

Note the following:

Warning

/N

This device and its components may only be used for the applications described in the catalog or the

technical description, and only in connection with devices or components from other manufacturers
which have been approved or recommended by Siemens.

This product can only function correctly and safely if it is transported, stored, set up, and installed
correctly, and operated and maintained as recommended.

Trademarks
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infringe upon the rights of the trademark owners.
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Welcome to STEP 7...

...the SIMATIC standard software for creating programmable logic control
programs in Ladder Logic, Function Block Diagram, or Statement List for SIMATIC
S7-300/400 stations.

About This Getting Started Manual

In this manual, you will get to know the basics of SIMATIC STEP 7. We will show
you the most important screen dialog boxes and the procedures to follow using
practical exercises, which are structured so that you can start with almost any
chapter.

Each section is split into two parts: a descriptive part, marked in gray, and a
process-oriented part, marked in green. The instructions start with an arrow in the
green margin and may be spread out over several pages, finishing in a full stop
and a box containing related topics.

Previous experience of working with the mouse, window handling, pull-down
menus, etc. would be useful, and you should preferably be familiar with the basic
principles of programmable logic control.

The STEP 7 training courses provide you with in-depth knowledge above and
beyond the contents of this Getting Started manual, teaching you how entire
automation solutions can be created with STEP 7.

Requirements for Working with the Getting Started Manual

In order to carry out the practical exercises for STEP 7 in this Getting Started
manual, you require the following:

* A Siemens programming device or a PC
* The STEP 7 software package and the authorization diskette

e A SIMATIC S7-300 or S7-400 programmable controller
(for Chapter 7 "Downloading and Debugging the Program™).

Additional Documentation on STEP 7
e STEP 7 Basic Information
e STEP 7 Reference Information

After you have installed STEP 7, you will find the electronic manuals in the Start

menu under Simatic > Documentation or alternatively, you can order them from
any Siemens sales center. All of the information in the manuals can be called up
in STEP 7 from the online help.

Have fun and good luck!
SIEMENS AG

STEP 7 Getting Started
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1 Introduction to STEP 7

1.1 What You Will Learn

Using practical exercises, we will show you how easy it is to program in Ladder
Logic, Statement List, or Function Block Diagram with STEP 7.

Detailed instructions in the individual chapters will show you step-by-step the
many ways in which you can use STEP 7.

Creating a Program with Binary Logic

In Chapters 2 to 7, you will create a program with binary logic. Using the
programmed logic operations, you will address the inputs and outputs of your CPU

(if present).

The programming examples in the Getting Started manual are based, among other
things, on three fundamental binary logic operations.

The first binary logic operation, which you will program later on, is the AND
function. The AND function can be best illustrated in a circuit diagram using two

keys.
Key 1 Key2 If both Key 1 and Key 2
are pressed, the bulb
~ /g lights up.
_—

The second binary logic operation is the OR function. The OR function can also be
represented in a circuit diagram.

é Key 3

o If either key 3 or key 4
Key 4 E@ i_s pressed, the bulb
lights up.

STEP 7 Getting Started 1-1
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Introduction to STEP 7

The third binary logic operation is the memory element. The SR function reacts
within a circuit diagram to certain voltage states and passes these on accordingly.

Memory Element

+ _é’_R s)

If key S is pressed, the bulb lights up
and remains lit until key R is pressed.

1-2 STEP 7 Getting Started
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Introduction to STEP 7

1.2 Combining Hardware and Software

Using the STEP 7 software, you can create your S7 program within a project. The
S7 programmable controller consists of a power supply unit, a CPU, and input and

output modules (I/O modules).

The programmable logic controller (PLC) monitors and controls your machine with
the S7 program. The 1/0O modules are addressed in the S7 program via the

addresses.

Programming
device cable

Programming device

Transferring a program

CPU

Machine to be

controlled

Output module

Power supply module

Input module

STEP 7 Getting Started
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Introduction to STEP 7

1.3 Basic Procedure Using STEP 7

Before you create a project, you should know that STEP 7 projects can be created
in different orders.

Designing the solution to the automation task

Creating a project (Chapter 2)

Option 1 Option 2
Configuring the hardware Creating a program
(Chapter 6) (Chapters 3 to 5)
Creating a program Configuring the hardware
(Chapters 3to 5) (Chapter 6)

I 4

Transferring the program to the CPU and debugging
(Chapter 7)

If you are creating comprehensive programs with many inputs and outputs, we
recommend you configure the hardware first. The advantage of this is that STEP 7
displays the possible addresses in the Hardware Configuration Editor.

If you choose the second option, you have to determine each address yourself, depending
on your selected components and you cannot call these addresses via STEP 7.

In the hardware configuration, not only can you define addresses, but you can also change
the parameters and properties of modules. If you want to operate several CPUs, for
example, you have to match up the MPI addresses of the CPUs.

Since we are only using a small number of inputs and
outputs in the Getting Started manual, we will skip the —
hardware configuration for now and start with the
programming.

1-4 STEP 7 Getting Started
A5E00171228-01



Introduction to STEP 7

1.4 Installing STEP 7

Regardless of whether you want to start with programming or configuring
hardware, you first have to install STEP 7. If you are using a SIMATIC
programming device, STEP 7 is already installed.

When installing the STEP 7 software
on a programming device or PC
without a previously installed version of
STEP 7, note the software and
hardware requirements. You can find
these in the Readme.wri on the

STEP 7 CD under

<Drive>:\STEP 7 \Disk1.

If you need to install STEP 7 first,
insert the STEP 7 CD in the CD-ROM
drive now. The installation program
starts automatically. Follow the
instructions on the screen.

If the installation does not start auto-
matically, you can also find the
installation program on the CD-ROM
under

<Drive>:\STEP 7 \Disk1\setup.exe.

Once the installation is complete and
you have restarted the computer, the
SIMATIC Manager "SIMATIC Manager" icon will appear

E on your Windows desktop.

If you double-click the "SIMATIC Manager" icon following installation, the STEP 7 Wizard
will be started automatically.

You can find additional notes on installation in the
Readme.wri file on the STEP 7 CD under
<Drive>:\STEP 7 \Disk1\Readme.wri.

STEP 7 Getting Started 1-5
A5E00171228-01



Introduction to STEP 7

1-6 STEP 7 Getting Started
A5E00171228-01



2 The SIMATIC Manager

2.1  Starting the SIMATIC Manager and Creating a Project

The SIMATIC Manager is the central window which becomes active when STEP 7
is started. The default setting starts the STEP 7 Wizard, which supports you when
creating a STEP 7 project. The project structure is used to store and arrange all

the data and programs in order.

Within the project, data are stored in the
form of objects in a hierarchical structure

SIMATIC Manager

STEP 7 Wizard: "New Project” [<]
"% Introduction 104]

STEP 7 Wizard: "New Project”

“fou can create STEP 7 projects quickly and easily using
the STEP 7 Wizard, You can then start programming
imrnedistely.

.0 1 Click ane of the following optiars:

i )
‘ "_‘. 7 "Next"to creale your project step-by-step

5') " "Make" lo create your project accarding b the preview.

W Display wigard on starting the STMATIC Manager ‘ Ml

I Black Name Symbolic Name
-l SIMATIC 300 Station H0B
= Jl CPUZ12 IFM(1)
E=-{ar] 57 Programi(1)
424 Blocks

Cyele Execution

< Bt ’Make Cancel Help

STEP 7 Getting Started
A5E00171228-01

The SIMATIC station and the CPU
contain the configuration and
parameter data of the hardware

The S7 program comprises all the
blocks with the programs necessary for
controlling the machine

Double-click the SIMATIC Manager
icon on the Windows desktop, then
select the File > Wizard "New
Project" menu command if the wizard
does not start automatically.

In the preview, you can toggle the
view of the project structure being
created on and off.

To move to the next dialog box, click
Next.

2-1



The SIMATIC Manager

STEP 7 Wizard: "New Project”

EES7 312-54C02- 0480
BES7 313-14D03-0480
EEST 314-14E04-0680
EES7 314-54E03-0480
BES7 315-14F03-04B0
EES7 315-24F03-04B0

I3 57 _Pro2
SIMATIC 300 Station
=+ (57 57 Program{1)
423 Blocks

STEP 7 Wizard: “New Project”

—

Cycle Execution

Time of Day Interrupt 0
Time of Day Intemipt 1
Time of Day Intermupt 2
Time of Day Intemipt 3

1C 300 Station
U314(1)
57 Pragram(1)

2-2

For the "Getting Started" sample
project, select CPU 314. The example
has been created in such a way that
you can actually select the CPU you
have been supplied with at any time.

The default setting for the MPI address
is 2.

Click Next to confirm the settings and
move to the next dialog box.

Select the organization block OB1 (if
this is not already selected).

Select one of the programming
languages: Ladder Logic (LAD),
Statement List (STL), or Function
Block Diagram (FBD).

Confirm your settings with Next.

STEP 7 Getting Started
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The SIMATIC Manager

Double-click to select the Suggested
“Zh What do you want to call your pm|ec‘l? 4(4] name |n the uPrOJeCt nameu f|e|d and
e (|GE‘“"g Stated J overwrite it with "Getting Started."
Existing projects: -

e .
- 5 Click Make to generate your new
Check. your new project in the previsw. . . .
Cick Make" o cedl e proes wih e dplayed project accordmg to the preview.
’J Gelting Started Block Name | Symbolic Name [
=18 SIMATIC 300 Station [RIT Cycle Execution
= Jl cPUB1AM)
=-{41] 57 Frogrami(1]
©£3 Blocks ——
< Back | Ilezt >(| Make )I Cancel Help

[o]

When you click the Make button, the SIMATIC Manager will open with the window for the
"Getting Started" project you have created. On the following pages, we will show you what
the created files and folders are for and how you can work effectively with them.

The STEP 7 Wizard is activated each time the program is started. You can deactivate this
default setting in the first dialog box for the Wizard. However, if you create projects without
the STEP 7 Wizard, you must create each directory within the project yourself.

You can find more information under
Help > Contents in the topic "Setting
Up and Editing the Project.”
STEP 7 Getting Started 2-3
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The SIMATIC Manager

2.2  The Project Structure in the SIMATIC Manager and How
to Call the Online Help

As soon as the STEP 7 Wizard is closed, the SIMATIC Manager appears with the
open project window "Getting Started." From here, you can start all the STEP 7
functions and windows.

Opening, organizing, and printing

projects
Editing blocks and inserting program Setting the window display and
components arrangement, selecting the

language, and making settings for
process data

Downloading the program

and monitoring the
hardware

Calling the STEP 7 online help

E‘SIMATIC Manager/ Getting Started

File Edit Inset FLC “iew DOptions “Window Help
D] 87| & |Bs|e] dinf [ 2 [2 =2 <MoFiler > =% %8s BEm| el
|

p#iS 7profGettin™

tting Started
] SIMATIC 300 Station

57 Program

{B Sources
= e ook

Prezz F1 to get Help.

The contents of the right-hand pane
show the objects and other folders
for the folder selected on the left

The contents of the left-hand pane
show the project structure

2-4 STEP 7 Getting Started
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The SIMATIC Manager

Calling the Help on STEP 7

F1

£? Help on STEP 7 [_[o] <]
o = =

Ausblenden  Zuiick  Vowits  Startssite Drul:ken Bluxxaw Db\edx

Inhalt ] index | Suchenl

Overview of STEP 7 1
What is STEP 77

STEP 7 is the standard software package
used for configuring and prograrming

Star
= Extended Uses of the STER 7 Sta
: SIMATIC programmable logic contrallers. It is

5 @ Installation and Authorization
) @ Warking Ot the ALtomstion Cancept
) @ Startup and Operation
EE Y Seﬂm Up and

pait of the SIMATIC industry software. There
are the following versions of the STEP 7
Standard package

T
| STEP 7 Wicr/D0S and STEP 7

& @ Editing Frojects varsior
5@ kamg With Projects in the Mutliproje

) @ Mare than One Uiser Editing Projects ‘
1

MicroAwin for simpler stand-alone
applications on the SIMATIC 57-200

= @ Configuring the Harctware

@ Configuring Connections and Data Ex.

1 @ Programming Blocks

= @ Configuring Messsges

) @ Cortroling and Moritoring Variables —|

& @ Commissioning and Service

@ Establishing an Online Connection an:

) @ Downloating and Uioaing

= @ Debugging

@ Diagnostics J_I

STEP 7 for applications on SIMATIC 57-
300/57-400, SIMATIC M7-300/M7-400,
and SIMATIC C7 with a wider range of
functions:

o Can be extended a5 an aption by the
software products in the SIMATIC
\r\dustry Safware (see also Extended

STEP 7 Getting Started
A5E00171228-01

Option 1:
Place the cursor on any menu
command and press the F1 key. The

context-sensitive help for the selected
menu command will appear.

Option 2:

Use the menu to open the STEP 7
online help.

The contents page with various help
topics appears in the left-hand pane
and the selected topic is displayed in
the right-hand pane.

Navigate to the topic you want by
clicking the + sign in the Contents list.
At the same time, the contents of the
selected topic are displayed in the
right-hand pane.

Using Index and Find, you can enter
search strings and look for the specific
topics you require.

Option 3:

Click on the "Start page" icon in the
STEP 7 Online Help to open the
information portal. This portal provides
compact access to major topics of the
Online Help, e.g.:

* Getting Started with STEP 7
* Configuring & Programming
* Testing & Debugging

* SIMATIC on the Internet

Option 4:

Click on the question mark button in
the toolbar to turn your mouse into a
help cursor. The next time you click on
a specific object, the online help is
activated.

2-5



The SIMATIC Manager

Navigating in the Project Structure

The project you have just created is

Ele Edit Inset PLE Miew Qptions window Help displayed with the selected S7 station
Dl 2@ & (e dil [o 2| [=. and CPU.

'E’?‘:;Gelling Started -- C:\Siemens\Step7\5 7proj\G etk

Click the + or — sign to open or close a

<|§b‘§:§= Getting Started
= SIMATIC 300 Station It folder.
=@ crus) 0B

You can start other functions later on
by clicking the symbols displayed in
‘ the right-hand pane.

Click the S7 Program (1) folder. This
contains all the necessary program
components.

You will use the Symbols component
in Chapter 3 to give the addresses
symbolic names.

The Source Files component is used to
store source file programs. These are
not dealt with in the Getting Started
manual.

27 Getting Started - C:\SIEMENS\SJEF+ todnroi\Gettin_1

=5 ot s = Click the Blocks folder. This contains
=2 U[] the OB1 you have already created
e and, later on, all the other blocks.

From here, you will start programming
in Ladder Logic, Statement List, or
Function Block Diagram in Chapters 4

25 Getting Started -- C:ASIEMENSASTIMP aZoroj\Gettin_1

= Click the SIMATIC 300 Station folder.
E‘ . E‘wrr -

ot All the hardware-related project data
are stored here.

You will use the Hardware component
in Chapter 6 to specify the parameters
of your programmable controller.

If you require further SIMATIC software for your automation task; for example, the optional
packages PLCSIM (hardware simulation program) or S7 Graph (graphic programming
language), these are also integrated in STEP 7. Using the SIMATIC Manager, for example,
you can directly open the relevant objects such as an S7 Graph function block.

=== You can find more information under Help > Contents in the topics "Working
Out the Automation Concept" and "Basics of Designing the Program Structure".
You can find more information on optional packages in the SIMATIC catalog
ST 70, "Components for Completely Integrated Automation.”
2.6 STEP 7 Getting Started
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3 Programming with Symbols

3.1 Absolute Addresses

Every input and output has an absolute address predefined by the hardware
configuration. This address is specified directly; that is, absolutely.

The absolute address can be replaced by any symbolic name you choose.

Digital input Digital output
module module
Byte O Byte 4

Bits 0to 7 Bits0to 7

.. . o)

Digital input 0 Digital output
module . module I
Byte 1 0 Byte 5

Bits0to 7 s Bits0to 7

Absolute address: | 1.5

Input Byte 1 Bit 5

STEP 7 Getting Started 3-1
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Programming with Symbols

3.2 Symbolic Programming

In the symbol table, you assign a symbolic name and the data type to all the
absolute addresses which you will address later on in your program; for example,
for input | 0.1 the symbolic name Key 1. These names apply to all parts of the
program and are known as global variables.

Using symbolic programming, you can considerably improve the legibility of the
S7 program you have created.

Working with the Symbol Editor

EE:IIarI::\SIEMENS\SIEF?\S?ulm\EellmJ NaVlgate In the pro]ect WlndOW
— e o : "Getting Started" until you reach
S7 Program (1) and double-click to

open the Symbols component.

Your symbol table currently only

Symbol Table Edit [nseit Wiew Oplions Window Help

[Fu& 4 me oo [Wor AL consists of the predefined organization
block OB1.
| o 7
Status addess  |batatvee | Click Cycle Execution and overwrite it
: ("_¥ 2 1 o1 with "Main Program" for our example.
Status | Symbal Address Data bype | Enter "Green L|ght" and "Q 4.0" in
1 ain Program o8 1 o8B 1 .
- Groan Light 5 a0 Taoar row 2. The data type is added
automatically.
| Comment | Click in the comment column of row 1
Q or 2 to enter a comment on the
symbol. You complete your entries in a
row by pressing Enter, which then
adds a new row.
Status | Symbol Address Data bype Enter "Red |_|ght" and "Q 4.1"inrow 3
1 Main Program o 1 o8 1
- Gresn Ligtt =5 Teoar and press Enter to complete the entry.
3 Red Light =] 41 BOOL
In this way, you can assign symbolic names to all
the absolute addresses of the inputs and outputs
which your program requires.
3.2 STEP 7 Getting Started
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Programming with Symbols

‘ E Save the entries or changes you have
made in the symbol table and close the

window.

Because there are lots of names for the entire "Getting Started" project, you can
copy the symbol table to your "Getting Started" project in Section 4.1.

§_'!__Symhul Editor - 57-Program(1]){Symbols)--ZEnD1_01_STEP7__STL_1-9\SIMATIC 300(1)AC... =] B3

Symbal Table  Edit Insert Wiew Options ‘Window Helo

EH[& & BE| o o |[msmbs =% | w2
&1 57-Program(1)(Symbols)--ZEn01_01_STEP7__STL_1-9\SIMATIC 300(1)\CPU314(1) _[O[=
Status | Symbol / Address Data type | Comment:
1 e Q 4.2 BOOL Retertive output
2 Automatic_On | 05 BOOL Far the memory function (switch on)
3 DE_Actual_Speed M 4 INT Actual speed for diesel engine
4 DE_Failure | 186 BOOL Die=el engine failure Here you can see the SymbOI
5 DE_Fan_On Q 56 BOoL Command for switching on diesel engine far table fOr the S7 Pl'Ogl'am n the
& DE_Follow_On T 2 TIMER Follawe-on time for diesel engine fan "Getting Started" examp|e for
7 DE_On Q 54 BOOL Command for switching on diesel engine .
a8 DE_Preset_Speed_R... |@ 55 BOoL Display "Diesel engine preset speed reache: Statement LISt'
9 Dlas.el e 2 FB 1 Data for diesel engine Genera"y Speaking, Only one
10 Engine FB 1 FB 1 Engine contral 2
it Fan R FC 1 Fan contral symbol table is created per
1z Green_Light @ 40 [Bool Result of AND query S7 program, regardless of
13 Hey_1 | 01 BooL Far the: AND guery i H
= which programming lan
14 Key_2 | 0.2 BOOL For the AMD query C p 09 a g cl guage
15 Hey_3 I 03 [BooL For the OR duery you have selected.
16 Hey_a | 04 BOOL For the OR gquery .
17 Main_Program oB 1 oB 1 This hlock contains the user program A" prlntable Ch_araCters (for
1 Manual_On I 06  |BooL For the memary function (switch off) example, special characters,
12 PE_Actual_Spesd w2 INT Actual speed for petrol engine Spaces) are permitted in the
20 PE_Faiure i i.2 BOOL Peiroi engine failure b I t bl
21 FE_Fan_On @ 52 |BOOL Command for swiching on petrol engine fan. SY 111001 tabIe.
22 PE_Fallowy_On T 1 TIMER Followe-on time for petrol engine fan
23 PE_On Q 50 BOOL Command for switching on petrol engine
24 PE_Preset_Speed_Re..|Q BN BOOL Display "Petrol engine preset speed reachec
25 Petrol DB 1 FB 1 Data for petrol engine
26 Red_Light Q 41 BOOL Result of OR query
27 S _Data 0B 3 e 3 Shared data block
28 Switch_Off_DE | 15 BOOL Switch off diesel engine
29 Switch_Off_PE | 1.1 BOOL Syvitch off petrol encgine
30 Switch_On_DE | 1.4 BOOL Switch on diesel engine
31 Switch_On_PE | 10 BOOL Switch on petral engine
32
v

The data type which was previously added automatically to the symbol table determines the
type of the signal to be processed for the CPU. STEP 7 uses, among others, the following
data types:

BOOL Data of this type are bit combinations. 1 bit (type BOOL) to 32 bits (DWORD).
BYTE
WORD
DWORD
CHAR Data of this type occupy exactly one character of the ASCII character set.
INT They are available for the processing of numerical values (for example, to calculate
DINT arithmetic expressions).
REAL
S5TIME Data of this type represent the different time and date values within STEP 7 (for
TIME example, to set the date or to enter the time value for a timer).
DATE
TIME_OF_DAY | You can find more information under Help >
I Contents in the topics “Programming Blocks*
and "Defining Symbols".
STEP 7 Getting Started 3-3
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4  Creating a Program in OB1

4.1 Opening the LAD/STL/FBD Program Window

Choosing Ladder Logic, Statement List, or Function Block Diagram

With STEP 7, you create S7 programs in the standard languages Ladder Logic
(LAD), Statement List (STL), or Function Block Diagram (FBD). In practice, and for

this chapter too, you must decide which language to use.

C

STEP 7 Getting Started
A5E00171228-01

Ladder Logic (LAD)
Suitable for users from the electrical engineering industry, for example.
"Green Lig

"KEY_]. r "Key_Z r bt
| | | {

| |
! |

Statement List (STL)
Suitable for users from the world of computer technology, for example.

A rr KE .E;r_ 1 rr
A. rr KE .3?._2 rr
= "Green Light"

Function Block Diagram (FBD)
Suitable for users from the world of circuit engineering, for example.

& "Green Lig

"KE?_]. o ht™

e ?_2 v

The block OB1 will now be opened according to the language you chose
when you created it in the project Wizard. However, you can change the
default programming language again at any time.
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Copying the Symbol Table and Opening OB1

If necessary, open your "Getting
Started" project. To do this, click the
Open button in the toolbar, select the
"Getting Started" project you created,
and confirm with OK.

fipen Project

zer projects ILib[anesl 5

dlGetting Started

Depending on which programming
language you have decided to use, in
the "Sample projects"” tab open one of
the following projects as well:

e ZEn0l1_05_STEP7__LAD_1-9
e ZEn0l1_01_STEP7__STL_1-9
or

e ZEn01_03 STEP7__FDB_1-9
Here you can see all three sample
projects displayed.

Navigate in the "ZEn01_XXX" until you
reach the Symbols component and
copy this by dragging and dropping it
to the S7 Program folder in your
project window "Getting Started."

Then close the window "ZEn0Q1_ XXX"

Drag and drop means that you click any object
with the mouse and move it whilst keeping the
mouse button depressed. When you release the
mouse button, the object is pasted at the selected
position.

Siioins s S i AT Double-click OB1 in the "Getting
ol Started" project. The LAD/STL/FBD

1 57 Proganl1)
(& Sou

program window is opened.

In STEP 7, OBL1 is processed cyclically by the CPU. The CPU reads line by line and
executes the program commands. When the CPU returns to the first program line, it has
completed exactly one cycle. The time required for this is known as the scan cycle time.

Depending on which programming language you have selected, continue reading in either
Section 4.2 for programming in Ladder Logic, Section 4.3 for Statement List, or Section 4.4
for Function Block Diagram.

You can find more information under Help > Contents I
in the topics “Programming Blocks" and "Creating
I Blocks and Libraries.”

4-2 STEP 7 Getting Started
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The LAD/STL/FBD Program Window

All blocks are programmed in the LAD/STL/FBD program window. Here, you can
see the view for Ladder Logic.

Inserting a new
network

Toggling "Program elements" and "Call

structure” on and off The most important program
elements for Ladder Logic and
(Pane can be placed anywhere in the Function Block Diagram

program window)

Changing the programming
language view

ELADISTLJ’FBD - [OB1 - Getting Started\SIMATIC 300 Station\CPU314(1]]

i3 File Edt Inset PLC Debug Yiew DOptions ‘Window Help =] x|
) = =~ = = T e o 1 i 3 1 )
i .l |Contents Of: ‘EnvironmenttlntefacehTEMP*
Interface 2| [wame Data Type  [Address  [Comment B
<P New network - El-f@& TEMP ‘= (OB1_EV_C.. |Byte 0.0 Bits 0-3 = 1 (Goming event), Bit...
H —
[ERETE i |-oic B8 OB1_EYV_CLASS ‘= OBRT_SCAN | Byte 10 1 {Cold restart scan 1 of 08 1),
Al = DB1_SCaN_1 ‘= 0B1_PRIO.. |Byte 20 Priarity of OB Execution
-@ OB1_PRIORITY ‘@ 01 0
Program it _|{= osi_rg The variable declaration table contains | —
elements @ OB1_RESERvED 2 . | OB1_RE the parameters and local variables for
(here for -8 OBI_FREV_CYCLE  [= 0B1PR - the block -
Ladder Logic) = 081 MIN CYCLE T [= 0BT Ml . [
and call =
structure Title and comment field for ]
) {GANE] the block or network
FT NEG
E‘ POS i
[-{£] Comparator | _I
{25 Converter |
(£ Counter |
E:I- D cal Program input line (also network
[+ Jumps
1 50 ioter et and current path)
[-{z& Floaling-point fct vI
4 I »
it Iogic £
| [ Program ... ILS_E Call str = ;I
=l
J TR DN 1z Error 2lnfa A FCrossPefererces A & Addessinfo_ A S Modfy G Diagnostics 7 Companson__J
Press Pl to getHelp The different tabs of the "Details" window
are for displaying error messages and
Help on the selected program element information on ad_dresses, for editing
symbols, monitoring addresses,
comparing blocks and for editing error
definitions for the process diagnostics.
Information on the selected program element
STEP 7 Getting Started 4-3
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4.2 Programming OB1in Ladder Logic
In the following section, you will program a series circuit, a parallel circuit, and the
set / reset memory function in Ladder Logic (LAD).
Programming a Series Circuit in Ladder Logic

If necessary, set LAD as the

programming language in the View
menu.

Ctrl+1
Chil+2
Crl+3

031 Click in the title area of OB1 and enter

Comment : "Cyclically processed main program,"
for example.
L € ‘ ‘ Select the current path for your first
e element.

| Click the button in the toolbar and
insert a normally open contact.

In the same way, insert a second
normally open contact.

_() Insert a coil at the right-hand end of
the current path.

}_‘ ”.7 ? The addresses of the normally open
‘ a — contacts and the coil are still missing in
the series circuit.

Check whether symbolic
representation is activated.

Dizplay with ¥ v Sumbolic Representation Chi+Q
- Symbollnformation Ctil+Shift+2
Symbaol Selection Clrl+7
v Comment Crl+S hift+k.

Address [dentification

4-4 STEP 7 Getting Started
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- X .2 Click the ??.? sign and enter the

' symbolic name "Key_1" (in quotation
marks). Alternatively, you can select
the name from the displayed pull-down
list.
Confirm with Enter.

}H 7.7 7.7 Enter the symbolic name "Key_2" for

‘ a — the second normally open contact.

}H 7.2 773 Enter the name "Green_Light" for the
‘ h coil.

‘ Moreen Lig You have now programmed a

"Key 17 "Key 2" b complete series circuit.
| Il 'l (] P

Save the block if there are no more
symbols shown in red.

STEP 7 Getting Started 4-5
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Programming a Parallel Circuit in Ladder Logic

o o o o o S
‘llet.wurk ib) Title:
e

Comment :

?2.2

2.2
f -
2.2
"Red Light
Key 3 "
|| |r J
[ Y
Key_ 4
K

4-6

Select Network 1.

Insert a new network.

Select the current path again.

Insert a normally open contact and a
coil.

Select the vertical line of the current
path.

Insert a parallel branch.

Add another normally open contact in
the parallel branch.

Close the branch (if necessary, select
the lower arrow).

The addresses are still missing in the
parallel circuit.

To assign symbolic addresses,
proceed in the same way as for the
series circuit.

Overwrite the upper normally open
contact with "Key_3," the lower contact
with "Key_4," and the coil with
"Red_Light."

Save the block.

STEP 7 Getting Started
A5E00171228-01
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a

Programming a Memory Function in Ladder Logic

HH:-|
[ .

777
SR
s a
iR

"Aautomstic
_Mode™

"Automatic

_on” SR

f——o= Q

"Manual On
"

—R

1=

Select Network 2 and insert another
network.

Select the current path again.

Navigate in the Program Elements
catalog under Bit Logic until you
reach the SR element. Double-click to
insert the element.

Insert a normally open contact in front
of each of the inputs S and R.

Enter the following symbolic names for
the SR element:

Upper contact "Automatic_On"

Lower contact "Manual_On"

SR element "Automatic_Mode"

Save the block and close the window.

If you want to see the difference between absolute and symbolic addressing, deactivate the
menu command View > Display > Symbolic Representation.

"Green Lig
"Key 2" he"
| |
1

Example:
Symbolic addressing in LAD

characters.

You can change the line break for symbolic addressing in the LAD/STL/FBD program
window by using the menu command Options > Customize and then selecting "Width of
address field" in the "LAD/FBD" tab. Here you can set the line break between 10 and 24

Example:
Absolute addressing in LAD

STEP 7 Getting Started

A5E00171228-01

You can find more information under Help > —
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing Ladder
Instructions."
4-7
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4.3 Programming OB1 in Statement List

In the following section, you will program an AND instruction, an OR instruction,
and the memory instruction set/reset in Statement List (STL).

Programming an AND Instruction in Statement List

AT Chrl+1
CsiL) Cule2
FED Ctrl+3
Dizplay with ¥ v Sumbolic Representation Chi+Q
Symbol Information Ctrl+Shift+C
Symbaol Selection Clrl+7
v Comment Crl+S hift+k.

Address [dentification

OE1l :< Title :’

Cortnent :

e vrozk 1ERCiaEE

Corrnent :

S

J!L rr KE ?_1 rr

4-8

If necessary, set STL as the
programming language in the View
menu.

Check whether symbolic
representation is activated.

Click in the title area of OB1 and enter
"Cyclically processed main program,”
for example.

Select the area for your first statement.

Type an A (AND) in the first program
line, a space, and then the symbolic
name "Key_1" (in quotation marks).

Complete the line with Enter. The
cursor jumps to the next line.

STEP 7 Getting Started
A5E00171228-01
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I o

rr KE .E;r_ 1 rr
rr KE .3?._2 rr
"Green Light"

In the same way, complete the AND
instruction as shown.

You have now programmed a
complete AND instruction. Save the
block if there are no more symbols
shown in red.

Programming an OR Instruction in Statement List

.
le twork D i

STEP 7 Getting Started
A5E00171228-01

o o

rr KE .5?._3 rr

r KE ?_3 r
r KE ET_"I'I r
"Red Light"

Select Network 1.

Insert a new network and select the
input area again.

Enter an O (OR) and the symbolic
name "Key_3" (in the same way as for
the AND instruction).

Complete the OR instruction and save
it.

4-9
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Programming a Memory Instruction in Statement List

Hic Select Network 2 and insert another

Pl network.
A "Automatic On' In the first line, type the instruction A
with the symbolic name
"Automatic_On."
"Automwatic On" Complete the memory instruction and
rautomatic Mode" save it. Close the block.

"Manual On"

E "Automatic Mode"

oo

If you want to see the difference between absolute and symbolic addressing, deactivate the
menu command View > Display > Symbolic Representation.
A "KE ¥_ 1 " Example:
KE?_E Symbolic addressing in STL
= "Green Light"
A I 0.1 Example:
2 1 0.2 Absolute addressing in STL
= 4.0
You can find more information under Help > -
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing STL
Statements."”
4-10 STEP 7 Getting Started
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4.4 Programming OB1 in Function Block Diagram

In the following section, you will program an AND function, an OR function, and a
memory function in Function Block Diagram (FBD).

Programming an AND Function in Function Block Diagram

L&D Crl+1

Crl+2
Chrl+3

Comment :

uecvork LECtaEE

Comment :

_—

g5 g

P2, 7 — P2 3

22, 72— —

Display with ¥ v Sumbolic Representation Cl+Q
- Symbolnformation Clrl+Shift+0
Sembaol Selection Chil+7
v Comment Clrl+Shift+k,

Address |dentification

STEP 7 Getting Started
A5E00171228-01

If necessary, set FBD as the
programming language in the View
menu.

Click in the title area of OB1 and enter
"Cyclically processed main program,"
for example.

Select the input area for the AND
function (below the comment field).

Insert an AND box (&) and an
assignment (=).

The addresses of the elements are still
missing in the AND function.

Check whether symbolic
representation is activated.

4-11



Creating a Program in OB1

Click on the ??.? sign and enter the

&
?2.2 symbolic name "Key 1" (in quotation

= marks). Alternatively, you can also

77, 72— — .
select the name from the displayed
pull-down list.
Confirm with Enter.
z Enter the symbolic name "Key_2" for
?2. 7 — .2 the second input.
z Enter the name "Green_Light" for the
?2. 72— 2?3 assignment.
22,7 — — )
Py "Green Lig You have now programmed a
"Key 1" — ht" complete AND function.
"KE?_Z L I— —
. If there are no more symbols shown in
red, you can save the block.
4-12 STEP 7 Getting Started
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Programming an OR Function in Function Block Diagram

HH:-|
[ .

Comment :

0|

==1
27, 7 — ?2.?
7?7, 7 — — )
==1 "Red Light
"KE? L g— "
"Key_f-l" ]

STEP 7 Getting Started

A5E00171228-01

1=

Insert a new network.

Select the input area again for the OR
function.

Insert an OR box (=1) and an
assignment (=).

The addresses are still missing in the

OR function. Proceed in the same way
as for the AND function.

Enter "Key_3" for the upper input,
"Key_4" for the lower input, and
"Red_Light" for the assignment.

Save the block.

4-13



Creating a Program in OB1

Programming a Memory Function in Function Block Diagram

Hr Select Network 2 and insert another
. network. Select the input area again
(below the comment field).

Navigate in the Program Elements
catalog under Bit Logic until you
reach the SR element. Double-click to
insert the element.

" Automatic Mode" Enter the following symbolic names for
the SR element:
wAutomaticon” = SR Set "Automatic_On"
s Reset "Manual_On"
Memory bit "Automatic_Mode"
"Manual on" —E o

E | Save the block and close the window.

a

If you want to see the difference between absolute and symbolic addressing, deactivate the
menu command View > Display > Symbolic Representation.

& "Green_Light"

"Key 1" —| Example:

= Symbolic addressing in FBD
'Key 2" = —

&
Example:
— 4.0 I

0.1 Absolute addressing in FBD
10.2 — —

You can change the line break for symbolic addressing in the LAD/STL/FBD program
window by using the menu command Options > Customize and then selecting "Address
Field Width" in the "LAD/FBD" tab. Here you can set the line break between 10 and 24
characters.

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing FBD
Statements."

4-14 STEP 7 Getting Started
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5 Creating a Program with Function Blocks

and Data Blocks

5.1 Creating and Opening Function Blocks (FB)

The function block (FB) is below the organization block in the program hierarchy. It
contains a part of the program which can be called many times in OB1. All the
formal parameters and static data of the function block are saved in a separate
data block (DB), which is assigned to the function block.

You will program the function block (FB1, symbolic name "Engine"; see symbol
table, page 3-3) in the LAD/STL/FBD program window, which you are now familiar
with. To do this, you should use the same programming language as in Chapter 4

(programming OB1).

157 Getting Started — C:ASIEMENS\STEP7AS 7proi\Gettin_1
-3 Getting Started
= SIMATIC 300 Station
e[ cPuat
2 (1) 87 Progami1

Function Black

STEP 7 Getting Started
ABE00171228-01

You should have already copied the
symbol table into your project "Getting
Started." If not, read how to do this on
page 4-2, copying the symbol table,
and then return to this section.

If necessary, open the "Getting
Started" project.

Navigate to the Blocks folder and
open it.

Click in the right-hand half of the
window with the right mouse button.

The pop-up menu for the right mouse
button contains the most important
commands from the menu bar. Insert a
function block as a new object.
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a

Eigenschaften - Funktionsbaustein [x]
General - Part 1 | General- Pan 2| Calls | Atrbutes |
Name: [V Muliple Instance Capabi
Symbalic Name: Engine
Syrbal Comment:
Created in Langua
Project Path: I
Storags location
of project [C\Siemens\Step73 7proj\Gettin 1
Code Inteiface
Date created: 12.04.2000 13.02:18
Last modified: 12.04.2000 13.02:18 12.04.2000 13:0218
Comment ’ =
< > Cancel Help
5 Getting Started - CASIEMENSAS TERZAS 7proj\Gettin_1
=& Getling Started
=] SIMATIC 300-Station ‘ D
=-[@ cruziam 081
1D $7-Programmil)

B Quelk

len
Basterne;

Double-click FB1 to open the
LAD/STL/FBD program window.

In the "Properties — Function Block"
dialog box, select the language in
which you want to create the block,
activate the check box "Multiple
instance FB," and confirm the
remaining settings with OK.

The function block FB1 has been
inserted in the Blocks folder.

Depending on which programming language you have selected, continue reading in either
Section 5.2 for Ladder Logic, Section 5.3 for Statement List, or Section 5.4 for Function
Block Diagram.

5-2

| You can find more information under Help >

Contents in the topics "Programming Blocks" and
"Creating Blocks and Libraries."

STEP 7 Getting Started
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5.2 Programming FB1 in Ladder Logic

We will now show you how to program a function block which can, for example,
control and monitor a petrol or diesel engine using two different data blocks.

All "engine-specific" signals are passed on as block parameters from the
organization block to the function block and must therefore be listed in the variable
declaration table as input and output parameters (declaration "in" and "out").

You should already know how to enter a series circuit, a parallel circuit, and a
memory function with STEP 7.

Declare / Define Variables First

T e — =8l Your LAD/STL/FBD program window is
Dlzle{E| & plele] | wlb) < open and the option View > LAD

i x]

(programming language) is activated.

= o [N
ol —'@7 Note that FB1 is now in the header,
peloly | [ 5T I

because you double-clicked FB1 to
open the program window.

Contents Of. ‘Envirormentiintertace’

FBL : Title:

AL Emer A 2 A ECrwssReferences  J GAddessinfe.  J & Modiy

Press F1 1o get Help [ 2 jofiine /A0 N1 Ln 1 finsert |

The variable declaration area consists of a variable overview (left pane) and of the
variable detail view (right pane).

In the variable overview, select the declaration types "IN", "OUT" and "STAT" one
after the other and enter the following declarations into the corresponding variable
details.

In the variable overview, click the corresponding cells and apply the entries from
the subsequent figures. You can select the data type from the pull-down list
displayed.

STEP 7 Getting Started
ABE00171228-01
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Caontents OF; Ernvironment\nterface N’

|Name Diata Type|Address | Initial Walue | Comment
‘B |Switch_On Boal 0.0 FALSE Switch on engine
‘B Switch_OfF  [Boal 0.1 FALSE Switch off engine
‘2 Failure Bool 0.z FALSE Engine failure, causes the engine to switch off

@ Actual_Speed
=]

nt 20 0 Actual engine speed

Caontents OF 'Environmentilnterface 0T

[Mame Data Type [Address [Initial Value  [Comment
‘@ [Engine_an Bool 40 FALSE Engine is switched on
‘= Preset_Speed_Reached [Boal 4.1 FALSE Preset speed reached

Contents OF ‘Environmentinterfacet S TAT

[Name Data Type|Address|initial Value|Comment
‘@ [Preset_Speed]Int 6.0 1500 Requested engine speed

—
=

Only letters, numbers, and the underscore are permitted
characters for the names of the block parameters in the
variable declaration table.

If all the columns required are not displayed in your
variable details, you can display it via the shortcut menu
command (via a right-mouse click).

Programming an Engine to Switch On and Off

‘ 77?7

s s = Insert a normally open contact, a

A s o— normally closed contact, and an SR

—r element in series in Network 1 using
the corresponding buttons in the
toolbar or the Program Elements
catalog.

<

£2.? Then select the current path

SR immediately before the input R.

2.7

P77 Insert another normally open contact.
e SO ™ J___ Selectthe current path immediately
272 before this contact.
Ok

|_). | _M_l _.I.l Insert a normally closed contact
parallel to the normally open contact.

5-4 STEP 7 Getting Started
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Check whether symbolic
representation is activated.

Select the question marks and enter the corresponding names from the variable
declaration table (the # sign is assigned automatically).

Enter the symbolic name "Automatic_Mode" for the normally closed contact in the
series circuit.

Then save your program.

"Automwatic #Engine On
#Switch On Mode” SR

|1 [

| T rd = 2
#owitch Of
£

||
| T B

#Failure

/1

STEP 7 Getting Started 5-5
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a

Programming Speed Monitoring

El Caompare

CMP | >=

sl

Insert a new network and select the
current path.

Then navigate in the Program
Elements catalog until you reach the
Compare function and insert a
CMP>=|,

Also insert a coil in the current path.

Select the question marks again and label the coil and the comparator with the

names from the variable declaration table.

Then save your program.

#Preset 3p
eed Reache

CMP == d

#ictual Sp
eed —INl

#Preset_Sp
eed —1uZ

|
1 1

When is the engine switched on and off?
When the variable #Switch_On has signal state "1" and the variable "Automatic_Mode" has
signal state "0," the engine is switched on. This function is not enabled until
"Automatic_Mode" is negated (normally closed contact).

When the variable #Switch_Off has signal state "1" or the variable #Fault has signal state
"0," the engine is switched off. This function is achieved again by negating #Fault (#Fault is
a "zero-active" signal and has the signal "1" in the normal state and "0" if a fault occurs).

How does the comparator monitor the engine speed?

The comparator compares the variables #Actual_Speed and #Setpoint_Speed and assigns
the result of the variables to #Setpoint_Speed_Reached (signal state "1").

5-6

You can find more information under Help > —
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing the Variable
Declaration” or in "Editing LAD Instructions."

STEP 7 Getting Started
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5.3 Programming FB1 in Statement List

STEP 7 Getting Started

A5E00171228-01

We will now show you how to program a function block which can, for example,
control and monitor a petrol or diesel engine using two different data blocks.

All "engine-specific" signals are passed on as block parameters from the
organization block to the function block and must therefore be listed in the variable
declaration table as input and output parameters (declaration "in" and "out").

You should already know how to enter an AND instruction, an OR instruction, and
the set/reset memory instructions with STEP 7.

Declare / Define Variable First

EHLAD/STL/FBD - [FB1 -- Getting Started\SIMATIC 300 Station\CPU314(1)]

D fi &% ol FLE Doty Yo Dt o L =2=  Your LAD/STL/FBD program window is

Dleze-&| @l o= (@] =[] cils| S i i >

EEETLI I EEEES open and the option V|evv_ ST_L

—a e (programming language) is activated.
e — =

B Newrework || | - [N
[ OUT

o o B Note that FB1 is now in the header,
r because you double-clicked FB1 to
open the program window.

F[AIPIMIN_ TiErer h 2o A 3 CrossHieleences A & Addessifo. A & Modiy

Press F1 to get Help I 8 loffine A Nw T Ln1 finseit |

The variable declaration area consists of a variable overview (left pane) and of the
variable detail view (right pane).

In the variable overview, select the declaration types "IN", "OUT" and "STAT" one
after the other and enter the subsequent declarations into the corresponding
variable details.

In the variable overview, click the corresponding cells and apply the entries from
the subsequent figures. You can select the data type from the pull-down list
displayed.
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Bool 0.1 FALSE Switch off engine
Bool 0.z FALSE Engine failure, causes the engine to switch off
int 20 0 Actual engine speed

Drmcmt crpmed vooebe
riesei Speed reaine

Programming an Engine to Switch On and Off

Check whether symbolic
representation is activated.

A #3mitch On Enter the corresponding instructions in
AN "Automatic Mode" Network 1.
3 #Engine Om
u] #Z3witch Off
oN fiFailure
R #Engine On
5-8 STEP 7 Getting Started
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Programming Speed Monitoring

L #ictual Speed Insert a new network and enter the
L #Preset_Speed corresponding instructions. Then save
=1

your program.

E = #Preset Speed Reached

When is the engine switched on and off?

When the variable #Switch_On has signal state "1" and the variable "Automatic_Mode" has
signal state "0," the engine is switched on. This function is not enabled until
"Automatic_Mode" is negated (normally closed contact).

When the variable #Switch_Off has signal state "1" or the variable #Fault has signal state

"0," the engine is switched off. This function is achieved again by negating #Fault (#Fault is
a "zero-active" signal and has the signal "1" in the normal state and "0" if a fault occurs).

How does the comparator monitor the engine speed?

The comparator compares the variables #Actual_Speed and #Setpoint_Speed and assigns
the result of the variables to #Setpoint_Speed_Reached (signal state "1").

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing the Variable
Declaration” or in "Editing STL Statements."

STEP 7 Getting Started 5-9
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5.4 Programming FB1 in Function Block Diagram

5-10

We will now show you how to program a function block which can, for example,
control and monitor a petrol or diesel engine using two different data blocks.

All "engine-specific" signals are passed on as block parameters from the
organization block to the function block and must therefore be listed in the variable
declaration table as input and output parameters (declaration "in" and "out").

You should already know how to enter an AND function, an OR function, and a
memory function with STEP 7.

Declare / Define Variables First

T R T — =24 Your LAD/STL/FBD program window is
ol 1= =T = e S s R N TN = H H >
S TR el s e open and the option Vlew FBD
s T [Fontents OF Ervionmen trteface’ (programmlng Ianguage) IS aCt'Vated

[ et = B
- Sm;znwmk ] J
{21 Comparator

Note that FB1 is now in the header,
- because you double-clicked FB1 to
open the program window.

5 &g Converter
Courts

G0 Floatirgpoirkfel.

=

[P\ T:Enor )}z fo A 3 Ciosshiclerences & Addessiio___J\__5 Modly

Press F1 to getHep. T jotine 8 N T Ln1 =

The variable declaration area consists of a variable overview (left pane) and the
variable detalil view (right pane).

In the variable overview, select the declaration types "IN", "OUT" and "STAT" one
after the other and enter the subsequent declarations into the corresponding
variable details.

In the variable overview, click the corresponding cells and apply the entries from
the subsequent figures. You can select the data type from the pull-down list
displayed.

STEP 7 Getting Started
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Contents OF 'EnvironmenthlnterfacelN'
IName Diata TypelAddress [initial value[Comment
B |Switch_Dn Boal 0.0 FALSE Switch an engine
‘B Switch_Off  |Bool 0.1 FALSE Switch off engine
‘B Failure Bool 0z FALSE Engine failure, causes the engine to switch off
G- STAT = Actual_Speed|int 20 0 Actual engine speed
@ TEMP [ -

Contents OF. ‘Environmentslnterfacet\0UT"

Diata Type |Address |Initial Value

Comment

@ Interface |Name
-4 & [Engine_On Bool
‘= Presel_Speed_Reached [Bool
; o TOUT |y
G4 GTAT
L@ TEMP

4.0 FALSE Engine is switched on

nnnnnnnnnnnnnnnn

Cantents OF ‘Environment\nterfacetSTAT

[Name Data Type|Address|initial value | Comment
‘@ [Preset_Speed|int 6.0 1500 Requested engine speed

Local block variables are indicated with a # sign
and are only valid in the block.

Global variables appear in quotation marks.
These are defined in the symbol table and are
valid for the entire proaram.

Programming an Engine to Switch On and Off

Insert an SR function in Network 1

using the Program Elements catalog
(Bit Logic folder).

Add an AND box at input S (Set), and
an OR box at input R (Reset).

&
?2. 7 — Q =
‘ SR )
?2. 7 — —69
T
==1
22, P —
22, P — —@
Dizplay with ¥ v Symbolic Representation Crl+0

Symbal Information
Symbal Selection

v Comment
Address |dentification

Cirl+Shift+3)
Chrl+7
Cirl+Shift+K,

Check whether symbolic
representation is activated.

STEP 7 Getting Started
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Click the ??.? sign and enter the corresponding names from the declaration table
(the # sign is assigned automatically).

Make sure that one input of the AND function is addressed with the symbolic
name "Automatic_Mode."

Negate the inputs "Automatic_Mode" and #Fault with the corresponding button
from the toolbar.

Then save your program.

&
#owitch On—
#Engine On

"Automatic =1 =]
_Mode" =} b 5

>:1
#zwitch of
£ —

#Failure = —E Q=
5-12 STEP 7 Getting Started
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Programming Speed Monitoring

Insert a new network and select the
input area.

o

E| ampare
g, L Then navigate in the Program

----- CHP | > Elements catalog under you reach the
= Compare function, and insert a
CMP>=,

Append an output assignment to the comparator and address the inputs with the
names from the variable declaration table.

Then save your program.

CHMP ==|
#Actual Sp #Preset 3p
eed I INi eed Reache

d
#FPreset 3p =

E eed — INZ

When is the engine switched on and off?

When the variable #Switch_On has signal state "1" and the variable "Automatic_Mode" has
signal state "0," the engine is switched on. This function is not enabled until
"Automatic_Mode" is negated (normally closed contact).

When the variable #Switch_Off has signal state "1" or the variable #Fault has signal state

"0," the engine is switched off. This function is achieved again by negating #Fault (#Fault is
a "zero-active" signal and has the signal "1" in the normal state and "0" if a fault occurs).

How does the comparator monitor the engine speed?

The comparator compares the variables #Actual_Speed and #Setpoint_Speed and assigns
the result of the variables to #Setpoint_Speed_Reached (signal state "1").

You can find more information under Help >
Contents in the topics "Programming Blocks," o
"Creating Logic Blocks," and "Editing the Variable
Declaration” or in "Editing FBD Instructions."

STEP 7 Getting Started 5-13
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5.5 Generating Instance Data Blocks and Changing Actual

5-14

Values

You have just programmed the function block FB1 ("Engine") and defined, among
other things, the engine-specific parameters in the variable declaration table.

In order for you to be able to program the call for the function block in OB1 later
on, you must generate the corresponding data block. An instance data block (DB)
is always assigned to a function block.

The function block is to control and monitor a petrol or diesel engine. The different
setpoint speeds of the engines are stored in two separate data blocks, in which
the actual value (#Setpoint_Speed) is changed.

By centrally programming the function block only once, you can cut down on the
amount of programming involved.

£ Getting Started — C-ASIEMENSAS TEP7AS 7proj\Gettin_1 The "Getting Started" prOjeCt is open in

Getting Started

=@ swrcaose | o the SIMATIC Manager.
O St o o
00 S s Navigate to the Blocks folder and click
O in the right half of the window with the

right mouse button.

| Insert a data block using the pop-up
ClmenlenObiset > S menu with the right mouse button.
coo < [rata Block. >
I
iz SR Dbl Apply the name DB1 in the “Properties
General - Part 1 | General - Part alle tibutes “ H
Nmmme'ﬁ ';;'” L : S = = Data Block* dialog box, then select the
e — application “Instance DB" in the
Symbol Comment: Dt for petiol engie adjacent pull-down list and apply the
pedsnk e 00 - name of the function block "FB1"

Fioject pal

e [EGemersvatepT\S TpronGetiT 1 a-SSigned' Apply all the Settings
Eade iofce displayed in the "Properties" dialog box
Date created: 09/10/2002 02:42:56 .
Last madified: 09/10/2002 02:42:56 09/10/2002 02:42:56 Wlth O K .
Comment: | ;l

| The data block DB1 is added to the
: "Getting Started" project.

Double-click to open DB1.

STEP 7 Getting Started
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Confirm the subsequent dialog with
byl e et as et i Pasnee s Yes {0 assign parameters to the
@ There is no functional difference for this DB to the editor in Instance data blocks

LADASTLAFED.

The DB could be opened with the DB editor in LAD/STL/FED [as in
Va1].

Da you want to open the DB with "Parameter assignment for data
blacks"?

¥ Ahways display this message for Open Instance DB

Next enter the value "1500" for the
B = petrol engine in the Actual Value
NS = column (in the row "Setpoint_Speed).
You have now defined the maximum
speed for this engine.

Save DB1 and close the program
window.

Address | Declaration | Name | Type | Iniial value | Actual value | Comment
s . = In the same way as for DB1, generate
; : another data block, DB2, for FB1.

Now enter the actual value "1200" for
the diesel engine.

E Save DB2 and close the program

window.

By changing the actual values, you have finished your preparations for controlling two
engines with just one function block. To control more engines, all you have to do is generate
additional data blocks.

The next thing you have to do is program the call for the function block in OB1. To do this,
continue reading in Section 5.6 for Ladder Logic, Section 5.7 for Statement List, or
Section 5.8 for Function Block Diagram, depending on the programming language you are

using.
You can find more information under Help > Contents
in the topics "Programming Blocks" and "Creating =
Data Blocks."
STEP 7 Getting Started 5-15

A5E00171228-01



Creating a Program with Function Blocks and Data Blocks

5.6 Programming a Block Call in Ladder Logic

All the work you have done programming a function block is of no use unless you
call this block in OB1. A data block is used for each function block call, and in this

way, you can control both engines.

OB1
Call

2% Getting Started — C:ASIEMENSASTERTAS 7proi\ G ettin_1

&P Getting Started
SIMATIC 300 Station b E T
=@ cPuInam FB1 el 082
42 57 Progran(1]
@ s

... —Actual speed

< Inzert Symbol S Ctrl+d

5-16

DB1
Petrol Engine
Data

=

FB1
"Engine"
| >t

Diesel Engine
Data

The SIMATIC Manager is open with
your "Getting Started" project.

Navigate to the Blocks folder and
open OB1.

Select network 3 and then insert
network 4 in the LAD/STL/FBD
program window.

In the program elements catalog
navigate to FB1 and insert it via a
double-click.

Insert a normally open contact in front
of each of the following: Switch_On,
Switch_Off, and Fault.

Click the ??? sign above "Engine" and
then, keeping the cursor in the same
position, click in the input frame with
the right mouse button.

Click on Insert Symbol in the shortcut
menu via a right-click on mouse
button. A pull-down list is displayed.

STEP 7 Getting Started
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L

Petral FE. 1 DE 1

Data for petral engine

Double-click the data block Petrol.
This block is then entered
automatically in the input frame in
guotation marks.

Click the question marks and after entering a quotation mark address all the other
parameters of the function block using the corresponding symbolic names in the
pull-down list.

"Petrol”

EN

"Switeh On PE"

| | Switch On
"Switch off PE"

| | Switch Off

"PE Failure"

i i Failure

"PE Actual Speed"”—|Actual Speed

"Engine'

0

ENOQ

Engine Cun|-"pgE on"

Preset_Speed Reac| "PE Preset Speed B
hed Feached”

STEP 7 Getting Started
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a

Program the call for the function block "Engine" (FB1) with the data block "Diesel"
(DB2) in a new network and use the corresponding addresses from the pull-down

"Switeh On DEM
| |

"Suitch Off_DE"
| |

"DE_Failure”
| |

"DE_Actual Speed’

"hiegel™
"Engine"
EN ENOQ
Engine_On
Switch Cn
Preset Zpeed Reac
hed
Switch OFf
Failure A

Actual Speed

=1

OB on®

"DE Preset Speed R
—eached”

signal "DE_xxx" is
assigned to each of the
variables for the diesel
engine.

Save your program and close the

block.

When you create program structures with organization blocks, function blocks, and data
blocks, you must program the call for subordinate blocks (such as FB1) in the block above
them in the hierarchy (for example, OB1). The procedure is always the same.

You can also give the various blocks symbolic names in the symbol table (for example,
FB1 has the name "Engine" and DB1 the name "Petrol").

You can archive or print out the programmed blocks at any time. The corresponding
functions can be found in the SIMATIC Manager under the menu commands File >
Archive or File > Print.

5-18

You can find more information under Help > Contents
in the topics "Calling Reference Helps" under rm—
"Language Description: LAD," and "Program Control
Instructions."

STEP 7 Getting Started
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5.7 Programming a Block Call in Statement List

All the work you have done programming a function block is of no use unless you
call this block in OB1. A data block is used for each function block call, and in this
way, you can control both engines.

DB1
Petrol Engine
Data

OB1
.-Engme M i F
Cal

L DB2

Diesel Engine
Data

It

il Sted SIS e The SIMATIC Manager is open with
R E T your "Getting Started" project.

=@ EPUSM[H
E1&0 57Por
@ So

Navigate to the Blocks folder and
open OB1.

HH2 Select network 3 and then insert
Pl network 4 in the LAD/STL/FBD
program window.

"Engine™ , "Petrol” Type CALL "Engine", "Petrol" in the

Switch On = code section and then press Enter.
Switch Off = All the parameters of the function block
Failure =

"Petrol" are displayed.

Aotual Speed

Position the cursor after the equals
Engine Cn

sign of Switch_On and press the right
mouse button.

Preset Speed Reached

Click on Insert Symbol in the shortcut
menu via a right-click on mouse
@E'@me i) button. A pull-down list is displayed.
STEP 7 Getting Started 5-19
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a

B 0B1_SCaN_1 Byte | 1.0
PE_Actual_Speed INT Mw 2
PE_Failure BoOL |1 1.z
S PE_Far On BOOL O 52
&1 FE_Follaw_On TIMER | T 1
PE_On BOOL (@ &0
FPE_Preset_Speed Reached BOOL | Q 51
43 Peatral FE 1 DE 1
3] Fed_Light BOOL @ 41
& Switch_0f_DE BOOL |1 15
Switch_Off_PE BoOL |1 14
LSl BOOL || 14
Q‘Elm? BOOL |1 10

a] |

"Petrol™

"Switch On PE"
"Switch Off PET
"PE_Failure”

Actual Speed "PE_Actual Spesd”
Engine_oOn ="PE_{m"

Preset_Speed Reached:="PE_Preset_Speed_ Reached”

CALL "Engine” ,
Switch oOn
Switch Off
Failure

"Diesel™
:="8witeh On DE"
:="8witeh Off DE"
:="DE_Failure"

Actusl Speed :="DE_Actual Speed”

Engine On :="DE_on"

Preset Speed Reached:="DE Preset Speed Reached"”

=1

CALL "Engine" ,
Switch On
Switch Off
Failure

Click the name Switch_On_PE. This
is taken from the pull-down list and
added automatically in quotation
marks.

Assign all the required addresses to
the variables of the function block
using the pull-down list.

A signal "PE_xxx" is assigned
to each of the variables for
the petrol engine.

Program the call for the function block
"Engine" (FB1) with the data block
"Diesel" (DB2) in a new network.
Proceed in the same way as for the
other call.

Save your program and close the
block.

When you create program structures with organization blocks, function blocks, and data
blocks, you must program the call for subordinate blocks (such as FB1) in the block above
them in the hierarchy (for example, OB1). The procedure is always the same.

You can also give the various blocks symbolic names in the symbol table (for example, FB1
has the name "Engine" and DB1 the name "Petrol").

You can archive or print out the programmed blocks at any time. The corresponding
functions can be found in the SIMATIC Manager under the menu commands File >
Archive or File > Print.

5-20

Instructions.”

You can find more information under Help > Contents u
in the topics "Calling Reference Helps" under
“Language Description: STL," and "Program Control

STEP 7 Getting Started
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5.8 Programming a Block Call in Function Block Diagram

All the work you have done programming a function block is of no use unless you
call this block in OB1. A data block is used for each function block call, and in this
way, you can control both engines.

DB1
Petrol Engine
Data

FB1
OB1
"Engine” M it
call
| —>1F

Diesel Engine
Data

Tt

'E""ﬁe.llmgslarledV—E\SIEMENS\EV’ Wiiproj\Gettin_1 The SIMATIC Manager |S Open Wlth
ELE SIMATIC 300 Staion i E EI) i " . " .
= g’“s;:m o 081 FE1 081 082 yOUI’ Gettlng Started prOJeCt
(£ Source Fi
=

Navigate to the Blocks folder and
open OB1.

HEe Select network 3 and then insert
1 network 4 in the LAD/STL/FBD
program window.

Then navigate in the Program
Elements catalog until you reach FB1
and insert this block.

All the engine-specific input and output

( "E“qi“e") variables are displayed.
.. —En

Click the ??? sign above "Engine" and
Engine onl then, keeping the cursor in the same

. —{suiteh off I position, click in the input frame with
Preset_Speed Reas the right mouse button.

.. —|8witch On

.. =—{Failure hed ...
.. —Actual Speed ENO L~
Click on Insert Symbol in the shortcut
menu via a right-click on mouse
Inset Symbol Ll button. A pull-down list is displayed.
STEP 7 Getting Started 5-21
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] Double-click the data block Petrol. It is
— taken from the pull-down list and
(Grerd) FB 1 DB 1 Datafor petrl encine entered automatically in the input

frame in quotation marks.

Address all the other parameters of the function block using the corresponding
symbolic names in the pull-down list.

"Petrol"”

"Engine™

., == EN

"Switch On PE" —&witch On
T Engine One="pg on"
"switch Off PE" ——Switch Off -
- Freset Speed Reac| "PE_Preset_Speed R
"PE Failure" —Failure hed l—eached™

"PE Actual Speed” —2ctual Speed ENC -

5-22 STEP 7 Getting Started
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Program the call for the function block "Engine" (FB1) with the data block "Diesel"
(DB2) in a new network and use the corresponding addresses from the pull-down

list.
A signal "DE_xxx" is assigned to
each of the variables for the
diesel engine.
"Diesel"
"Engine"
. —EN
"Switech On DE" —Switch On
Engine Onf="DE On"
"Switch Off DE" ——Switch Off
Preset Speed Reac| "DE FPreset Speed R
"DE Failure' — Failure hed lcached”
"DE Actual Ipeed” —Actual Speed ENC |-

E Save your program and close the
E _| block.

When you create program structures with organization blocks, function blocks, and data
blocks, you must program the call for subordinate blocks (such as FB1) in the block above
them in the hierarchy (for example, OB1). The procedure is always the same.

You can also give the various blocks symbolic names in the symbol table (for example, FB1
has the name "Engine" and DB1 the name "Petrol").

You can archive or print out the programmed blocks at any time. The corresponding
functions can be found in the SIMATIC Manager under the menu commands File > Archive
or File > Print.

You can find more information under Help > Contents
in the topics "Calling Reference Helps" under r—
"Language Description: FBD," and "Program Control
Instructions."
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6

6.1 Configuring Hardware

Configuring the Central Rack

You can configure the hardware once you have created a project with a SIMATIC
station. The project structure which was created with the STEP 7 Wizard in
Section 2.1 meets all the requirements for this.

The hardware is configured with STEP 7. These configuration data are transferred
to the programmable controller later on "downloading” (see Chapter 7).

I Getting Started -- C:\SIEMENS35%

oi\Gettin_1

P ATy

iy

Hardware

-5 Getting Starled
B cIriATIC 200 S aiion) (

The starting point is the open SIMATIC
B e cpm Manager together with the "Getting
et Started" project.

(£ Blacks

Open the SIMATIC 300 Station folder
and double-click the Hardware
symbol.

The "HW Config“ window opens. The CPU you selected on creating the project is
displayed. For the "Getting Started" project, this is CPU 314.

@{;HW’ Config - [SIMATIC 300 Station [Configuration] --

Getting Started]

m Station Edit [nesert FLC Miew Opton: Window Help = '|§'|1|
nlkmlgqlﬁ Il =l o leal al ol Ten el ool .;;I|
Dler|a~= (8 81 o) s |5 S) 55 2
=0 UR | ﬁl Profile [Standard [~
1 B
2 CPU314(1] . PROFIBUS DP
3 Rack with individual slots PROFIBUS-PA
4 SIMATIC 300
5 B SIMATIC 400
5 ezl SIMATIC PC Based Control 300/400
7 -8 SIMATIC PC Station
o LI
I ;|_I Hardware
Catalog
4= | m LR
|
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2 | [ CPUIT4(] BEST 314-14 12| | |
3 | | | | | |
4 Configuration table with | ]
g I 2
5 the MP1 and I/O PROFIBLIS-DP slaves for SIMATIC 57, M7, angd/
7 addresses — CW’
|
Fress F1 to get Help. | / b
Short information on the
selected element
Help on the selected element
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[H]aus

=

[#]ans

= SimaTic 300

- B Ps-300

SIMATIC 300

- =3 5M-300

[~

First you require a power supply
module. Navigate in the catalog until
you reach the PS307 2A and drag and
drop this onto slot 1.

Navigate until you find the input
module (DI, Digital Input) SM321
DI32xDC24V and insert this in slot 4.
Slot 3 remains empty.

In the same way, insert the output
module SM322 DO32xDC24V/0.5A in
slot 5.

In order to change the parameters (for example, address) of a module within a
project, double-click the module. However, you should only change the

parameters if you are sure you know what effects the changes will have on your
programmable controller.

No changes are necessary for the "Getting Started" project.

Order Mumber

MPI Address

| &dd... | O... | Comment

EEST 307-1BAD0-0A40

Module
PS307 24
CPLI314(1]

EES7 314-1AE04-04B0

2

(S ENTRITSTE £
=

Di32sDC24Y
D320 C24W /0. 54

BESY 321-1BLO0-04A0

EES7 322-1BLO0-0AA0

== |||~ o

—|=

< Save and Campile >

a

The data are prepared for transfer to
the CPU using the menu command
Save and Compile.

Once you close the "HW Config"
application, the System Data symbol
will appear in the Blocks folder.

You can also check your configuration for errors using the menu command Station >
Consistency Check. STEP 7 will provide you with possible solutions to any errors which

may have occurred.

You can find more information under Help > Contents in
the topics "Configuring theHardware" and "Configuring
Central Racks."
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Downloading and Debugging the Program

7.1 Establishing an Online Connection

Using the supplied project "GS-LAD_Example" or the "Getting Started" project you
have created and a simple test configuration, we will show you how to download
the program to the programmable logic controller (PLC) and then debug it.

You should have:
e Configured the hardware for the "Getting Started" project (see Chapter 6)

e Set up the hardware according to the installation manual

Example of a series circuit (AND function):

Output Q 4.0 is not to light up (diode Q 4.0 lights up on the digital output module)
unless both Key 1 0.1 and Key | 0.2 are pressed. Set up the test configuration
below using wires and your CPU.

Power supply Operating mode Rack Programming
(on / off) keyswitch device with
STEP 7

software

peCo

9?690

-
Er
p
«

XK XX X-X-X- - L")

il
b
]

Q
=
=
%

Programming device
cable

Connection bridge

STEP 7 Getting Started
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Configuring the Hardware

To assemble a module on the rail, proceed in the order given below:

a

Attach the module onto the bus connector

Hang the module on the rail and swing it downwards
Screw the module in place

Assemble the remaining modules

Insert the key in the CPU once you have finished assembling all the modules.

You can still carry out the test even if you are using different hardware to that shown in the
diagram. You simply have to keep to the addressing of the inputs and outputs.

STEP 7 offers you various ways of debugging your program; for example, using the
program status or by means of the variable table.

7-2

You can find more information on configuring the
central rack in the manuals "S7-300, Hardware and
Installation / Module Specifications" and "S7-400 /
M7-400 — Hardware."
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7.2

Downloading the Program to the Programmable Controller

You must have already established an online connextion in order tp download the

program.

Applying Voltage

Switch on the power supply using the
ON/OFF switch. The diode "DC 5V"
will light up on the CPU.

Turn the operating mode switch to the
STOP position (if not already in
STOP). The red "STOP" LED will light

up.

Turn the operating mode switch to the
MRES position and hold it there for at
least 3 seconds until the red "STOP"
LED starts flashing slowly.

Release the switch and, after a
maximum of 3 seconds, turn it to the
MRES position again. When the
"STOP" LED flashes quickly, the CPU
has been reset.

If the "STOP" LED does not start
flashing quickly, repeat the procedure.

Downloading the Program to the CPU

STEP 7 Getting Started
A5E00171228-01

Now turn the operating mode switch to
"STOP" again to download the
program.
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=

SIMATIC M anager

Start the SIMATIC Manager and open
the "Getting Started" project in the
"Open" dialog box (if it is not already
open).

In addition to the "Getting Started
Offline" window, open the "Getting
Started ONLINE" window. The online
or offline status is indicated by the
different colored headers.

Navigate in both windows to the
Blocks folder.

The offline window shows the situation
on the programming device; the online
window shows the situation on the
CPU.

Select the Blocks folder in the offline
window and then download the
program to the CPU using the menu
command PLC > Download.
Confirm the prompt with OK.

The program blocks are displayed in
the online window when you download
them.

STEP 7 Getting Started
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Switching on the CPU and Checking the Operating Mode

NP — Turn the operating mode switch to

RN — RUN-P. The green "RUN" LED lights

oo :’@ up and the red "STOP" LED goes out.
The CPU is ready for operation.

When the green LED lights up, you
can start testing the program.

If the red LED remains lit, an error has
occurred. You would then have to
evaluate the diagnostic buffer in order

E to diagnose the error.

Downloading individual blocks

In order to react to errors quickly in practice, blocks can be transferred individually to the

CPU using the drag and drop function.

When you download blocks, the operating mode switch on the CPU must be in either

"RUN-P" or "STOP" mode. Blocks downloaded in "RUN-P" mode are activated immediately.

You should therefore remember the following:

* If error-free blocks are overwritten with faulty blocks, this will lead to a plant failure. You
can avoid this by testing your blocks before you download them.

* If you do not observe the order in which blocks are to be downloaded — first the
subordinate blocks and then the higher-level blocks — the CPU will go into "STOP"
mode. You can avoid this by downloading the entire program to the CPU.

Programming online

In practice, you may need to change the blocks already downloaded to the CPU for test
purposes. To do this, double-click the required block in the online window to open the
LAD/STL/FBD program window. Then program the block as usual. Note that the
programmed block immediately becomes active in your CPU.

You can find more information under Help > —
Contents and then under "Downloading and
Uploading" and under "Establishing an Online
Connection and Making CPU Settings".

STEP 7 Getting Started 7-5
A5E00171228-01



Downloading and Debugging the Program

7.3 Testing the Program with Program Status

Using the program status function, you can test the program in a block. The
requirement for this is that you have established an online connection to the CPU,
the CPU is in RUN or RUN-P mode, and the program has been downloaded.

EGelln:;%:::;DDES\SIEMENS\STEF?\S?pmi\Em ol Open OBl |n the prOJECt W|ndOW
e | & o = o "Getting Started ONLINE."
= Qg[l] System Data FB1 DBt DB2
) = = = The LAD/STL/FBD program window is
= O =2 = opened.
E E
Activate the function Debug >
Monitor.
( v Monitar >

Debugging with Ladder Logic

rray 1 "rey 2n Mareen Light" The series circuit in Network 1 is
. S displayed in Ladder Logic. The current
path is represented as a full line up to
Key 1 (I 0.1); this means that power is
already being applied to the circuit.

Debugging with Function Block Diagram

L Lighe The signal state is indicated by "0" and
Koyt . Dopt T  "1." The dotted line means that there is
"Rey 2" -4 -4 1 noresultof logic operation.

Debugging with Statement List

=[[Fno] sTa] Stendard For Statement List the following is
A "Eey 17 1} 1} 1] H H .
A rEerze o | o 0 displayed in tabular form:
= "Green Light” 0| o 0 — Result of logic operation (RLO)
- _ Status bit (STA)

— Standard status (STANDARD)

Using Options > Customize
you can change the way in
which the programming
language is represented during
testing.
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5O m
OO000000

Soaramaa

OO0 0000
Seamramos

| "Fey_1" "Fey_2" "Green Light

1| Y
| 1T 1T L

1 &
Key 17— "Green Light”
1 =
Key 2" —]
][ rro| sTa| standard
A "Key_1" 1 1 1]
A "Key_ 2" 1 1 0
= "green Light" 1 1 0

a

Now press both keys in your test
configuration.

The diodes for input 1 0.1 and | 0.2 light
up on the input module.

The diode for output Q 4.0 lights up on
the output module.

In the graphic programming languages
Ladder Logic and Function Block
Diagram, you can trace the test result
by following the change in color in the
programmed network. This color
change shows that the result of logic
operation is fulfilled up to this point.

With the Statement List programming
language, the display in the STA and
RLO columns changes when the result
of logic operation is fulfilled.

Deactivate the function Debug >
Monitor and close the window.

Then close the online window in the
SIMATIC Manager.

obtain a better overview.

We recommend you do not completely download extensive programs onto the CPU to run
them, because diagnosing errors is more difficult due to the number of possible sources of
an error. Instead, you should download blocks individually and then test them in order to

I Status."

I You can find more information under Help > Contents
in the topics "Debugging” and "Testing with Program

STEP 7 Getting Started
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7.4 Testing the Program with the Variable Table

You can test individual program variables by monitoring and modifying them. The
requirement for this is that you have established an online connection to the CPU,
the CPU is in RUN-P mode, and the program has been downloaded.

As with testing with program status, you can monitor the inputs and outputs in
Network 1 (series circuit or AND function) in the variable table. You can also test
the comparator for the engine speed in FB1 by presetting the actual speed.

Creating the Variable Table

3 Geling Starled
EFE SIMATIC 300 Station

=-[{ cruztan)
B 57

252 Getting Started — C:ASIEMENS\STEP?AS 7proiSGettin_1

Insert Mew Object

3

“ariable Table

Properties - Variable Table

General-Part 1 | General- Part 2| ttibutes |

Mame: [VATT

Symbalic Marme:

Spmbal Comment: |

Project path: [
Storage location

of project

Code
Date created:
Last modified:

[CASiemenshStepriS 7pra Gettin™1

09/10/2002 03:27:26
09/10/2002 03:27:26

Interface

03/10/2002 03:27:26

Camment [

E
Cancel Help

S [ SIMATIC 300 Station
- [f cruziam
(& 57 Program

7-8

System data

2 [

The starting point is the SIMATIC
Manager again with the open project
window "Getting Started Offline."

Navigate to the Blocks folder and click
in the right half of the window with the
right mouse button.

Use the right mouse button to insert a
Variable Table from the pop-up menu.

Apply the default settings by closing
the "Properties” dialog box with OK.

Alternatively, you can assign a symbol
name to the variable table and enter a
symbol comment.

A VAT1 (variable table) is created in
the Blocks folder.

Double-click to open VAT1,; the
"Monitoring and Modifying Variables"
window will open.

STEP 7 Getting Started
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At first, the variable table is empty. Enter the symbolic names or the addresses for
the "Getting Started" example according to the illustration below. The remaining
details will be added when you complete your entry with Enter.

Change the status format of all the speed values to DEC (decimal) format. To do
this, click the corresponding cell and select DEC format using the right mouse

button.

Table Edit Inzert PLC “ariable “iew Options Window Help
w| D@ S| &|m|e] o] x| 2a[ 8] K| Srfar]| ]|
[ET2fE 23 st el

.
Al Address Symbol Dizpl| Status walue | Modily value|

1 1 o “Key 1" BoaL

2 | 02 Ky 2 BoaL

3 Q40 "Green_Light" BoaL

Pl

5 Mw 2 "PE_Actual_Speed” DEC

53 DE1.DBW B "Petal" Preset_Speed DEC

7 o 51 "PE_Preset_Speed Reached" (BOOL

a

| kw4 "DE_Actual_Speed DEC

10 DE2.DBW B! "Diesel" Prezet_Speed DEC

11 O &b "DE_Preset_Speed Reached" i BOOL

12

Press F1 for help. [ 2 |Difline |Abs < 5.2 L

| E| Save your variable table.

Switching the Variable Table Online

%l Click the ON button in the toolbar of

the "Monitoring and Modifying
Variables" window to establish a
connection to the configured CPU. The
word "ONLINE" will appear in the

status bar.
P — Set the keyswitch of the CPU to
RN — RUN-P (if you have not already done
s S0).

STEP 7 Getting Started 7-9
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Monitoring Variables

Click the Monitor Variables button in
the toolbar. The operating mode of the
CPU is displayed in the status bar.

VAT_1 -~ @Gelting Staited\SIMATIC 300 5tation\CPU314[11757 Program |
Al Address Symbol Displagfformat| Statuyalue | ¢
ot ey 1 B00 e

[ ey 2" falu] § [ |
0 40 “Green_Light" e
—

Press Key 1 and Key 2 in your test
configuration and monitor the result in
the variable table.

1|aum4

The status values in the variable table
will change from false to true.

Modifying Variables

Enter the value "1500" for the address MW?2 in the Modify Value column and
"1300" for the address MWA4.

A Var - VAT 1
Table Edit FLC ‘“arable “iew Option: Window Help

#| Dl=ld| 8| d|mlelolc] x| =l M
al£le 28 Al lale

=] E3

Sofes | || o]

Inzert

MPl = 2 [directiy)

|ﬁ[ VAT 1 -- @Getting Started\SIMATIC 300 StationACPU3I14[1)A57 Program 0. |_ |EI| xl
- A Addiess Symbol Dizplay format| Status walue |Modify value

1 |01 “Kep 1" BOOL " tiue

2 | 0z ey 2" BOOL " tiue

3 G40 “lareen_Light” BOOL i_i true

4

a] Wi 2 "PE_Actual Speed” DEC 0 150

B DB1.DBW & "Petrol”.Preset_Speed DEC 1500

7 o 51 "PE_Preset_Speed Reached" : BOOL " truie

]

3| Mw 4 DE_Actual Speed” DEC 0 12>

10 DBEZDEW 6:'"Diesel" Preset_Speed DEC 1200

11 o &h "DE_Preset_Speed Reached" : BOOL " tiue

12 I

—

<> [RUN

[Bbs<52 [ 4

i

Transfer the modify values to your

CPU.
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Following transfer, these values will be processed in your CPU. The result of the
comparison becomes visible.

Stop monitoring the variables (click the button in the toolbar again) and close the
window. Acknowledge any queries with Yes or OK.

A Var - VAT 1 [_ O[]
Table Edit Inzet PLC ‘“ariable “iew Options ‘Window Help

& Di|d| S| slmlel o] x| 2=ls K| Sfer v 69|
el 2] sl [&le

ﬁl YAT 1 - i@Getting Started\SIMATIC 300 Station\CPU314(1)\57 Program 0. |_ |EI| Xl
| ;" Address Symbol Display format| Status walue | Modify value|

1 I 01 ey 1" BOOL

2 |02 ey 2 BOOL

3 o 40 “Green_Light' BOOL

4

] M 2 "PE_Actual_Speed” DEC 1500

53 DE1.DBW B "Petral”" Preset_Speed DEC

7 o &1 "PE_Preset_Speed_Reached" : BOOL

g

| M 4 "DE_Actual Speed DEC 1300

10 DE2.DBW B! "Diesel" Prezet_Speed DEC

11 O &b "DE_Preset_Speed Reached" i BOOL

12 I

E MPI = 2 [directly] < RUNT labs<52 [ 4

Very large variable tables often cannot be displayed fully due to the limited screen space.
If you have large variable tables, we recommend you create several tables for one

S7 program using STEP 7. You can adapt the variable tables to precisely match your own
test requirements.

You can assign individual names to variable tables in the same way as for blocks (for

example, the name OB1_Networkl instead of VAT1). Use the symbol table to assign new
names.

| You can find more information under Help > Contents

in the topics "Debugging" under "Testing with the
Variable Table."
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7.5 Evaluating the Diagnostic Buffer

7-12

If, in an extreme case, the CPU goes into STOP while processing an S7 program,
or if you cannot switch the CPU to RUN after you have downloaded the program,
you can determine the cause of the error from the events listed in the diagnostic

buffer.

The requirement for this is that you have established an online connection to the

CPU and the CPU is in STOP mode.

RUNP =
RUN =

MRAES e

27 Getting Started -~ C:\SIEMENS\STEP7\S 7proi\Gettin_1

B SIMATIC 300 Station
=+ cruzam

]
@

< Hardware Diagnostics >

DiagnosticSeting

Diagnosing Hardware - Quick View

Path: Getting Started\SIMATIC 300 Station\CPU314(1]557 Program(1]

e —

Madule Information.

CPU / faulty modules:

Open Stalion Orline
Update
IV Display quick view when diagnasing hardware
Close Help

First turn the operating mode switch on
the CPU to STOP.

The starting point is the SIMATIC
Manager again with the open project
window "Getting Started Offline."

Select the Blocks folder.

If there are several CPUs in your
project, first determine which CPU has
gone into STOP.

All the accessible CPUs are listed in
the "Diagnosing Hardware" dialog box.
The CPU with the STOP operating
mode is highlighted.

The "Getting Started" project only has
one CPU which is displayed.

Click Module Information to evaluate
the diagnostic buffer of this CPU.

If only one CPU is connected, you can
query the module information for this
CPU directly using the menu command
PLC > Module Information.
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The "Module Information” window provides you with information on the properties
and parameters of your CPU. Now select the "Diagnostic Buffer" tab to determine
the cause of the STOP state.

P il nformation —CP0 577 H ||

Path: !Getting Started\SIMATIC 300 StationsCPLI3 Operating mode of the CRU: &) STOP

Status: #%9 Emor Mot a force job
Time Syztem I Communication I Stacks I
General td ey I Scan Cycle Time
Events: [™ | Eilter setinas active ™| Dimneincliding ERU e tire differetice

2 I e - o Socaa T
3 04:13:35:825 pm 04/25/01  Regueszt for manual warm restart
4 04:13:35:791 pm 04/25/01  Mode transition from STOP ta STARTUP

5} 04:13:02:818 pm 04/25/01  STOP caused by programming error [0 not loaded or n...
[ 04:13:02:818 pm 04/25/01  FC not loaded

7

8

04:13:02:813 pm 04/25/01  Mode tranzition from STARTUP to BUM

04:13:02:813 pm 04/25/01  Request for manual warm restart ;I
Detailz an Event: 1 of 100 Ewvent ID:  16H# 4303
STEIF caused I:!_U ztop zwitch being activated The "Open Block" button is
Previous operating mode: RUN disabled, because there was no

Requested operating mode: STOR [internal]
Incoming event

Save bz, | Help on Event |
Cloze I Update | Print... | Help |

error in the block in the "Getting
Started" project.

Wpen Blask

The latest event (number 1) is at the top of the list. The cause of the STOP state is
displayed. Close all windows except for the SIMATIC Manager.

If a programming error caused the CPU to go into STOP mode, select the event and click
the "Open Block" button.

The block is then opened in the familiar LAD/STL/FBD program window and the faulty
network is highlighted.

With this chapter you have successfully completed the "Getting Started" sample project,
from creating a project through to debugging the finished program. In the next chapters,
you can extend your knowledge further by working through selected exercises.

You can find more information under Help > Contents
under "Diagnostics" in the topic "Calling the Module

Information."
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8 Programming a Function

8.1 Creating and Opening Functions (FC)

Functions, like function blocks, are below the organization block in the program
hierarchy. In order for a function to be processed by the CPU, it must also be
called in the block above it in the hierarchy. In contrast to the function block,
however, no data block is necessary.

With functions, the parameters are also listed in the variable declaration table, but
static local data are not permitted.

You can program a function in the same way as a function block using the
LAD/STL/FBD program window.

You should already be familiar with programming in Ladder Logic, Function Block
Diagram, or Statement List (see Chapters 4 and 5) and also symbolic
programming (see Chapter 3).

Open Project If you have worked through the
"Getting Started" sample project in

Chapters 1 to 7, open this now.

=r projects | Libraries] 5

If not, create a new project in the
SIMATIC Manager using the menu
command File > "New Project"
Wizard. To do this, follow the
instructions in Section 2.1 and rename
the project "Getting Started Function."

We will continue with the "Getting
Started" project. However, you can still
carry out each step using a new

project.
Eell—E\SIEMENS\SIEP7\57pmi\EellirLl Navigate to the Blocks folder and
EI SIMATIC 300 Station ﬁ D D EI' .
& cPustm System Data om FB1 DB1 Open |t
= (511 57 Program(1)
= = Click in the right half of the window

o with the right mouse button.
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< Insert Mew Object , 3

General-Patt 1 | General- Pat 2| Calls | Atibutes |

Hame (interal) FCi

Language

Symbal
Symbal comment: =T

Fraject path. I

Storage location

of project [CASiemens\Step?5 Fproj\Gettin_1
Cods Interface
Date created: 12.04.2000 13.02:18
Last modified: 12.04 2000 130218 12.04.2000 130218
Comment: ’ =
sbprechen | Hile |

&% Getling Started -- C:ASIEMENS\STEP7AS 7proi\GeMtin_1

B @« = =

System Data FB1 i DB2

Getting Started
=3 SIMATIC 300 Station
=-[§] cPUR4)
E)-51) 57 Program(1)
@l SouceFies
a

Insert a Function (FC) from the
pop-up menu.

In the "Properties — Function" dialog
box, accept the name FC1 and select
the required programming language.

Confirm the remaining default settings
with OK.

The function FC1 is added to the
Blocks folder.

Double-click to open FC1.

In contrast to the function block, no static data can be defined in the variable declaration
table for a function.

The static data defined in a function block are retained when the block is closed. Static data
can be, for example, the memory bits used for the "Speed” limit values (see Chapter 5).

To program the function, you can use the symbolic names from the symbol table.

8-2

Program".

You can find more information under Help > Contents in the
topics "Working Out the Automation Concept," "Basics of
Designing a Program Structure," and "Blocks in the User
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8.2 Programming Functions

U

In this section, you will program a timer function in our example. The timer function
enables a fan to switch on as soon as an engine is switched on (see Chapter 5),
and the fan then continues running for four seconds after the engine is switched
off (off-delay).

As mentioned earlier, you must specify the input and output parameters of the
function ("in" and "out" declaration) in the variable detail view.

The LAD/STL/FBD program window is open. You work with this variable detail
view in the same way as with the detail view for the function block (see Chapter

5).

Enter the following declarations:

Contents OF 'Ereeironment’nkerf acet N’

T PETIIER

i3 Interface IName Data Type [Comment

@ ‘2 |Engine_0n Boaol Signal far switching on the engine

=0 OUT ‘= Timer_Function [Timer Timer function used for the switch-off delay
e IN_OUT o

L@ TEMP

Contents OF ErvvironmentsInterfacet0OUT!

HF Interfacs
=

E-4

..

20k IN_OUT

& TEMP

Inama

Data Tupe  IComment

p =]

‘& |Fan_on Bool

Signal for switching on the fan

Programming the Timer Function in Ladder Logic

PP

STEP 7 Getting Started
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?2.? E

El (@] Timers

D 5_OFFDT G; 72

v BI-...

R BCD-...

Select the current path for entering the
Ladder instruction.

Navigate in the Program Elements
catalog until you reach the element
S_OFFDT (start off-delay timer), and
select the element.

Insert a normally open contact in front

of input S.
Insert a coil after output Q.
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8-4

Select the question marks, enter "#" and select the corresponding names.

Set the delay time at input TV of S_OFFDT. Here, S5T#4s means that a constant
has been defined with the data type S5Time#(S5T#), lasting four seconds (4s).

Then save the function and close the window.

#Tiwer Function

#Engine oOn S OFFDT
| 5 N Q
1
S5THAZ TV BI
—R BCD

#Fan_On
R |

W |

The "#Timer_Function" is started with

.. the input parameter "#Engine_On." Later

on when the function is called in OB1, it
will be supplied once with the
parameters for the petrol engine and
once with the parameters for the diesel
engine (for example, T1 for
"PE_Follow_on"). You will enter the
symbolic names of these parameters
later in the symbol table.

Programming the Timer Function in Statement List

A #Engine Om

L 3I5TH#AS

=)y #Timer Function
A #Tiwer Function
= #Fan On

If you are programming in Statement
List, select the input area below the
network and enter the statement as
shown here.

Then save the function and close the
window.
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Programming the Timer Function in Function Block Diagram

If you are programming in Function Block Diagram, select the input area below the
network and enter the FBD program below for the timer function.

Then save the function and close the window.

#Timer Function

S_OFFOT
#Engine On-—3 BIf...

S5THLS — TV BCD ... #Fan_On

E ... —R Q

In order for the timer function to be processed, you need to call the function in a block
which is higher up in the block hierarchy (in our example, in OB1).

You can find more information under Help >
Contents in the topics "Calling Reference Helps,
"The STL, FBD, or LAD Language Description,"
and "Timer Instructions."
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8.3 Calling the Function in OB1

The call for the function FC1 is carried out in a similar way to the call for the
function block in OB1. All the parameters of the function are supplied in OB1 with
the corresponding addresses of the petrol or diesel engine.

Since these addresses are not yet defined in the symbol table, the symbolic
names of the addresses will now be added.

An address is part of a STEP 7 statement and specifies
what the processor should execute the instruction on.
Addresses can be absolute or symbolic.

2% Gotling Started - CASIEMENS\STEP7\S7proi\Gettin_|
-5 Getting Started
=3 SIMATIC 300 Station

=-[§] cPUR4)
E)-51) 57 Program(1

The SIMATIC Manager is open with
the "Getting Started" project or your
= = new project.

Navigate to the Blocks folder and
open OB1.

The LAD/STL/FBD program window
opens.

Programming the Call in Ladder Logic

HH You are in LAD view. Select network
. No. 5 and insert a new network No. 6.

Then navigate in the Program
Elements catalog until you reach FC1
and insert the function.

_ Insert a normally open contact in front
B of "Engine_On."

??. 7 {Timer_Function

Using the menu command View >
Display > Symbolic Representation,
you can toggle between symbolic and
absolute addresses.

Click the question marks for the FC1 call and insert the symbolic names.
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"EE On"
[

"PE_Follow On' —

TRan

EN

Engine On

Timer Function

ENO

Fan On

[-"PE_Fan_ On"

Program the call for the function FC1 in Network 7 using the addresses for the
diesel engine. You can do this in the same way as for the previous network (you
have already added the addresses for the diesel engine to the symbol table).

"DE On"
[

STEP 7 Getting Started
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"DE_Follow On'"—

"Fan"
EN

Engine On

Timer Function

ENO

Fan On

"DE_Fan On'"

Save the block and then close the
window.
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Programming the Call in Statement List

Hetwork 6 : Controlling the Fan for the Petrol Engine If you are programming in Statement
e o ven onr List, select the input area below a new
Timer Punction: =B Follow on" network and enter the STL statements
- - shown here.
Wetwork 7: Controlling the Fan for the Diesel Engine
C;f;mjgg" g on Then save the call and close the
Timer Function:="DE Follow On" window.

Fan_On "DE_Fan_On"

Programming the Call in Function Block Diagram

If you are programming in Function Block Diagram, select the input area below a
new network and enter the FBD instructions shown below.

Then save the call and close the window.

fRan"

.. —EN

"PE On" —Engine_on Fan Onf="pg Fan On"
"PE Follow On" —Timer Function ENO—
"Ean"
.. —EN
"DE On" —Engine On Fan Ooni—"pE Fan on"

E "DE Follow on™ —Timer Function ENO |-

The call for the functions was programmed as an unconditional call in our example; that is,
the function will always be processed.

Depending on the requirements of your automation task, you can make the call for a
function or function block dependent on certain conditions; for example, an input or a
preceding logic operation. The EN input and the ENO output are provided in the box for
programming conditions.

You can find more information under Help >
Contents and then under "Calling Reference =
Helps," in the topics "The LAD, FBD, or STL
Language Description".
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9 Programming a Shared Data Block

9.1 Creating and Opening Shared Data Blocks

If there are not enough internal memory bits in a CPU to save all the data, you can

store specific data in a shared data block.

The data in a shared data block are available to every other block. An instance
data block, on the other hand, is assigned to one specific function block, and its
data are only available locally in this function block (see Section 5.5).

You should already be familiar with programming in Ladder Logic, Function Block
Diagram, or Statement List (see Chapters 4 and 5) and also symbolic

programming (see Chapter 3).

Upan Project

Uszer frgfects |Libraries] S

Getting Started

27 Getling Started - C:ASIEMENS\S TEP7\S TproitG ettin_1
=2 Getting Stated
=5 SIMATIC 300 Station
=- @ cPusld)
£ 57 Pogian(1)
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If you have worked through the
"Getting Started" sample project in
Chapters 1 to 7, open this now.

If not, create a new project in the
SIMATIC Manager using the menu
command File > "New Project"
Wizard. To do this, follow the
instructions in Section 2.1 and rename
the project "Getting Started Function."

We will continue with the "Getting
Started" project. However, you can still
carry out each step using a new
project.

Navigate to the Blocks folder and
open it.

Click in the right half of the window
with the right mouse button.
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9-2

< Inzert Mew Dbject > 4 Ca

D ata Block
Properties - Data Block =]
General - Pa 1 | General- Pat 2] Calls | Atirbutes |
Mame and type: [Shered DB = =

Sumbolic Name: 5_Dats

Symbol Comment [Shared data biock

Created in Language: DB B

Project path: [

Starage locatian
of project

[C\Giemens\StepT\5 praiVGetinT
Code Inleiface:
Date crealed 03/10/2002 04:21:42

Last modifiedt 03/10/2002 04:21:42 03/10/2002 04:21:42

Comment

"I»_

Insert a Data Block (DB) from the
pop-up menu.

In the "Properties — Data Block" dialog
box, accept all the default settings with
OK.

Use the "Help* Button for further
information.

The data block DB3 has been added to
the Blocks folder.

Double-click to open DB3.

Remember: In Section 5.5, you
generated an instance data block by
activating the option "Data block
referencing a function block." In
contrast, using "Data block" you
create a shared data block.

Programming Variables in the Data Block

Tnitial valcomment

[eaporery placeholer veriahis

Enter "PE_Actual_Speed" in the Name
column.

Click with the right mouse button to
select the type using the menu
command Elementary Types > INT
from the pop-up menu.

In the example below, three shared data are defined in DB3. Enter these data
accordingly in the variable declaration table.

Address |Hame Type Initial valiComment
0. STRUCT
+0.0 |DB_VAR INT Temporary placeholder wariahle
- 0l T TR

The variables for the actual speeds in the data block
"PE_Actual_Speed" and "DE_Actual_Speed" are treated
in the same way as the memory words MW2
(PE_Actual_Speed) and MW4 (DE_Actual_Speed). This
can be seen in the next chapter.

El Save the shared data block.
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Assigning Symbols

Sumbol Table

You can also assign symbolic names
to data blocks.

Open the Symbol Table and enter the
symbolic name "S_Data" for the data
block DB3.

If you copied the symbol table from a sample
project (zEn01_02_STEP7__STL_1-10,
zEn01_06_STEP7__LAD_1-10 or
zEn01_04_STEP7__FBD_1-10) to your
"Getting Started" project in Chapter 4, you do
not need to add any symbols now.

5 Data

a

| Address |Data Type/ Comment

OB 3 DB

=l

3 | Shared data block

Save the symbol table and close the
"Symbol Editor" window.

Also close the shared data block.

Shared data blocks in the variable declaration table:

Using the menu command View > Data View, you can change the actual values of the data
type INT in the table for the shared data block (see Section 5.5).

Shared data blocks in the symbol table:

In contrast to the instance data block, the data type for the shared data block in the symbol
table is always the absolute address. In our example, the data type is "DB3." With the
instance data block, the corresponding function block is always specified as the data type.

| YOU can find more information under Help > Contents in the topics —
"Programming Blocks" and "Creating Data Blocks."

STEP 7 Getting Started
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10 Programming a Multiple Instance

10.1 Creating and Opening a Higher-Level Function Block

In Chapter 5 you created a program for controlling an engine with the function
block "Engine" (FB1). When the function block FB1 was called in the organization
block OB1, it used the data blocks "Petrol" (DB1) and "Diesel" (DB2). Each data
block contained the different data for the engines (for example, #Setpoint_Speed).

Now imagine that you require other programs to control the engine for your
automation task; for example, a control program for a rapeseed oil engine, or a
hydrogen engine, etc.

Following the procedure you have learned so far, you would now use FB1 for each
additional engine control program and assign a new data block each time with the

data for this engine; for example, FB1 with DB3 to control the rapeseed oil engine,
FB1 with DB4 for the hydrogen engine, etc. The number of blocks would increase

significantly as you created new engine control programs.

By working with multiple instances, on the other hand, you can reduce the number
of blocks. To do this, you create a new, higher-level function block (in our example,
FB10), and call the unchanged FB1 in it as a "local instance." For each call, the
subordinate FB1 stores its data in data block DB10 of the higher-level FB10. This
means that you do not have to assign any data blocks to FB1. All the function
blocks refer back to a single data block (here DB10).

The data blocks DB1 and DB2 are integrated in DB10. To do
this, you must declare FB1 in the static local data of FB10.

FB10
CALL FBL1 (for petrol engine)
CALL FBL1 (for diesel engine)

OB1
CALL FB10, DB10

FB1
= Ty =
% DB10
D "Petrol engine" data
"Diesel engine" data

eogine: it
3

You should already be familiar with programming in Ladder Logic, Function Block
Diagram, or Statement List (see Chapters 4 and 5) and also symbolic
programming (see Chapter 3).

STEP 7 Getting Started
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@

“ |

User projects | Librariesi 5

|
[aetting Started

=@ Getting Started
= SIMATIC 300 Station
=- [ cruzta)
E)(5 §7 Progan(l)
BT

Properties - Function block

General - Part 1 | Gener

thibutes |

> |
Hame: [Fe10 ¥ ultiple Instance Capabil

S ymbolic Name

Symbol Comment: [

CreatedinLanguage:  [STL -

Fioject Path: [

Starage location

of praject: [ESiemens\tepT\aTprapGettin_1

Code Interface

Dale created 18/05/2000 08:48:27

Last modifed, 18/05/2000 08:48:27 18/05/2000 08.48:27

Commert ’ =]
E Cancel Help

If you have worked through the
"Getting Started" example in Chapters
1to 7, open the "Getting Started"
project.

If not, open one of the following
projects in the SIMATIC Manager:
ZEn01_05 STEP7__LAD_1-9 for
Ladder Logic,
ZEn01_01_STEP7__STL_1-9 for
Statement List

ZEn01_03 STEP7__FBD_1-9 for
Function Block Diagram.

Navigate to the Blocks folder and
open it.

Click with the right mouse button in the
right half of the window and insert a
function block using the pop-up menu.

Change the name of the block to FB10
and select the required programming
language.

Activate Multiple instance FB (if
necessary) and accept the remaining
default settings with OK.

FB10 has been added to the Blocks
folder. Double-click to open FB10.

You can create multiple instances for any function block, even for valve control programs,
for example. If you want to work with multiple instances, note that both the calling and the
called function blocks must have multiple instance capability.

You can find more information under Help > Contents in the topics
"Programming Blocks" and "Creating Blocks and Libraries."
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10.2 Programming FB10

To call FB1 as a "local instance" of FB10, in the variable detail view a static
variable must be declared with a different name for each planned call of FB1.
Here, the data type is FB1 ("Engine").

Declare / Define Variables

FB10 is open in the LAD/STL/FBD program window. Transfer the declarations of
the subsequent image to your variable detail view. To do this, select the
declaration types "OUT", "STAT" and "TEMP" one after the other and make your
entries in the variable detail view. Select "FB <nr>" as the data type for the
declaration type "STAT" from the pull-down list and replace the character string
"<nr>" with the "1".

Contents OF ‘Environmentinterface\OUT'
Interface EName [Data Type |Address |Initial Walue|Comment
‘@ Preset_Speed_Reached [Bool 0.0 FALSE Bath engines have reached the preset speed

) o

Contents OF ‘Environmenty nterface’\S TAT'

Interface Hhame Datalyne| Addiess:| iniliakvalls | Comment
== m | @ FPetrol_Engine |Engine 2.0 Firstlocal instance of FB1 "Engine"
O OUT 163 Diesel_Engine |Engine  10.0 Second local instance of FB1 "Engine”
@T )
g
Contents OF ‘Ernvironmentsnterface TEMP'
Rl ey i v [Ty T ey [P PR [ ———" +
iMame Diata Type | Address Commant
‘B PE_Preset_Speed_Reached |Bool oo Preset speed reached {petrol engine)
‘2 DE_Preset Speed_Reached |Bool 0.1 Preset speed reached {diesel engine)
i=1

The declared local instances will then appear in the
"Program elements" tab under "Multiple Instances."

STEP 7 Getting Started 10-3
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10-4

Programming FB10 in Ladder Logic

multiple-i

Insert the call "Petrol_Engine" as the

nstance block

"Petrol_Engine" in Network 1.

Then insert the required normally open contacts and complete the call with the

symbolic nhames.

"&witch On PE"
| |

"switch Off PE"
||

"PE_Failure"
| |
1T

"3_Data".PE_Actual
_Speed

#Petrol Engine
EN ENO

Engine_on
Switch On
Preset_Speed Reac
hed
Switch Off

"PE Cn'

#PE_Preset_Speed R
Feached

The "Actual_Speed" for the engines is not
taken from a memory bit (see Section 5.6

Failure

onwards), bl

ut from a shared data block

(see Section 9.1). The general address

Actual Speed assignment

is as follows:

"Data_Block".Address, for example:
"S_Data".PE_Actual_Speed.

Insert a new network and program the call for the diesel engine. Proceed in the
same way as for Network 1.

"Switch On DE"

"guitch Off DE"
||
1

"DE_Failure"
| |

"S_Data".DE_Actual
_Speed

#Diezel Engine
EN ENC

Engine_0On

Switch On
Preset_Speed Reac
hed

Switch Off

Failure

Actual Speed

"DE on"

#DE_Freset_Speed R
—eached

STEP 7 Getting Started
A5E00171228-01



Programming a Multiple Instance

Insert a new network and program a series circuit with the corresponding
addresses. Then save your program and close the block.

[

Use the respective temporary
variables. You will recognize the
temporary variables in the pull-down
menu by the symbols displayed on the
left.

Then save your program and close the
block.

#PE Preset_Speed R #DE_Preset_Speed R #Preset Speed Reac

eached
| | | |

eached hed

oy
L |

The temporary variables
("PE_Setpoint_Reached" and
"DE_Setpoint_Reached") are
supplied to the output parameter
"Setpoint_Reached," which is then
processed further in OB1.

Programming FB10 in Statement List

CALL #FPetrol Engine

Switch On :="Switch On_ PE"

Switch Off 1="Switch Off PE"

Failure :="PE_Failure"

Actual Speed :="3_Data".PE_Actual Speed
Engine On :="PE_On"

Preset_Speed Reached:=#PE_Preset_Speed Reached

CALL #Diesel Engine

Switch On :="Switch On DE"

Switch Off i="Switch Off DE"

Failure :="DE_Failure"

Actual 3Zpeed :="3_Data".DE_Actual 3peed
Engine On r="DE_On"

Preset Speed Reached:=#DE Preset ZSpeed Reached

A #PE_Preset Speed Reached
A HDE_Preset_Speed Reached
= #Preset Speed Reached

STEP 7 Getting Started
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If you are programming in Statement
List, select the input area under a new
network and enter the STL instructions
shown here.

Then save your program and close the
block.
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Programming FB10 in Function Block Diagram

If you are programming in Function Block Diagram, select the input area under a
new network and enter the FBD instructions below.

Then save your program and close the block.

. —EN
"Switch On PE" —Switch On
"Switch Off_PE" —Switch Off

"PE Failure" —{Failure

"S Data".PE_Actual

Speed —Actual Speed ENO |-

#Petrol Engine

Engine Onj=

Preset Speed Reac
hed -

. —EN
"Switch On DE" —{Switech On
"Switch OFf DE" —{Switch Off

"DE Failure" —Failure

"3 Data".DE_Actual

Speed —{ictual Speed ENO —

#Diesel Engine

Engine Oni—

Preset Speed Reac
hed —

H#PE_Preset Speed R
eached —_

#DE Preset Speed R

gached —_

#Preset Speed Reac
hed

a

"PE_On"

#PE_Preset Zpeed R
eached

"DE_on"

H#DE_Preset Speed R
eached

for functions (FCs) is not possible.

To edit both calls for FB1 in FB10, FB10 must be called itself.
Multiple instances can only be programmed for function blocks. Creating multiple instances

topics "Programming Blocks,
"Multiple Instances in the Variable Declaration."

You can find more information under Help > Contents in the
" "Creating Logic Blocks," and

10-6

STEP 7 Getting Started
A5E00171228-01




Programming a Multiple Instance

10.3 Generating DB10 and Adapting the Actual Value

The new data block DB10 will replace the data blocks DB1 and DB2. The data for
the petrol engine and the diesel engine are stored in DB10 and will be required
later for calling FB10 in OB1 (see "Calling FB1 in OB1" from Section 5.6 onwards).

5 Getting Started - <Offi

Gstiing Started

]
= SIMATIC 300-Station

line> (Projekt) -- C:\SIEMENS\S TEP7\S 7proj\Gettin_1

] ) i i

=-[@ cruzym
E-z7] 57 Progiam(1] System Data FB1 DB1 DB2
081 VATI FC1 083

Properties - Data Block

General-Pat 1 | Gen
Hame and type
Symbolic Name:
Symbol Comment
Created in Language:
Project path

Storage lacation
of project

Date created:
Last modifiet

eral -Pat2] Calls | Atirbute:
N
) (=) & z

3 DB B

[CSiemensStep7\S 7profGettin1

Code Interface
09/10/2002 04:32:50

03/10/2002 04:32:60 09/10/2002 04:32:60

Comment [ |
| 4
Cancel Help

Open Data Block

By default, instance data blocks are opened with "Parameter assignment

There iz na functional difference for this OB to the editor in

@ for daia biocks" as of STEF 7 ¥5.2 {zee Heip]

LADASTLAFBD

The DB could be opened with the DB editor in LAD/STLAFED (az in

VE 1),

Do wou want to open the DB with "Parameter assignment for data

blocks"?

¥ Always display this message for Open Instance DB

Help |
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Create the data block DB10 in the
Blocks folder of the "Getting Started"
project in the SIMATIC Manager using
the pop-up menu.

To do this, change the name of the
data block to DB10 in the dialog box
"Properties - Data Block", then select
the application "Instance DB" in the
adjacent pull-down list". In the right
pull-down list, select the function block
"FB10" to be assigned and confirm the
remaining settings with OK.

The data block DB10 has been added
to the "Getting Started" project.

Double-click on DB10..

In the following dialog box, answer with
Yes to open the instance DB. Select
the menu command View > Data
View.

The data view displays each individual
variable in DB10, including the “internal”
variables of the two calls for FB1 (“local
instances").

The declaration view displays the variables
as they are declared in FB10.

10-7



Programming a Multiple Instance

Change the actual value of the diesel engine to "1300," save the block, and then

close it.
Address | Declaration| Mame Type | Initial value | Acktual value | Comment

it 0.0 out Preset_Spesd_Reached BOOL FALSE FaLSE Both engines hiave reached the presst spesd
z 2.0 | stat:in Petrol_Engine, Switch_on BOOL | FALSE FALSE Switch on engine
3 2.1 | stat:in Petrol_Engine, Switch_OFF BOOL | FALSE FALSE Switch of f engine
4 2,2 | statiin Petrol_Engine.Failure BCQOL | FALSE FALSE Engine failure, causes the engine ko switch of f
5 4,0 | stat:in Petrol_Engine. Actual_Speed INT |0 1] Actual engine speed
=] 6,0 | stak:out Petrol_Engine.Engine_on BOOL | FALSE FALSE Engine is switched on
7 6,1 | stakiout Petrol_Engine.Preset_Speed_Reached BOOL | FALSE FALSE Preset speed reached
g 2.0 | skat Petrol_Engine Preset Speed INT 1500 1500 Requested engine sneed
9 10,0 | skat:in Diesel_Engine, Switch_on BOOL | FALSE FALSE Switch on engine

T 101 | sbatin Cimzal Eroine Sudkch O3FF ool | EaloE Al T p———

i 10,1 [statiin Diesel_Engine. Switch_GFF BOOL FALSE FaLSE Swsitch off engine

1 10,2 | skatin Diesel_Engine. Failure BOOL | FALSE FALSE Engine failure, causes the engine to switch off
iz 12.0 | statin Diesei_Engine. Actuai_Speed IMT |0 1] Artual engine speed

13 14.0 | skat:out Diesel_Engine. Engine_On BOOL | FALSE FALSE Engine is switched on

14 14,1 | skat:out Diesel_Engine.Preset_Speed_Reached BOOL |FALSE reset speed reached

E 15 16.0 | skak Diesel_Engine.Preset_speed INT 1500 € Qquested engine speed
e

All the variables are now contained in the variable declaration table of DB10. In the first half,
you can see the variables for calling the function block "Petrol_Engine" and in the second
half the variables for calling the function block "Diesel _Engine" (see Section 5.5).

The "internal" variables of FB1 retain their symbolic names; for example, "Switch_On." The
name of the local instance is now placed in front of these names; for example,
"Petrol_Engine.Switch_On."

You can find more information under Help > Contents in the
topics "Programming Blocks" and "Creating Data Blocks." -
10-8 STEP 7 Getting Started
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10.4 Calling FB10in OB1

The call for FB10 is made in OB1 in our example. This call represents the same
function which you have learned while programming and calling FB1 in OB1 (see
Section 5.6 onwards.). Using multiple instances, you can replace Networks 4 and
5 programmed from Section 5.6 onwards.

Open OB1 in the project in which you
have just programmed FB10.

=3 AT
=-[@ cruztym
-1 87 Program(1)
(B Source Files
aloci

If you copied the symbol table from a sample
project (ZEn01_01_STEP7__STL_1-10,
ZEn01_05_STEP7__LAD_1-10 or
ZEn01_03_STEP7__FBD_1-10) to your
"Getting Started" project in Chapter 4, you do
not need to add any symbols now.

DET0

Defining Symbolic Names

The LAD/STL/FBD program window is open. Open the symbol table using the
menu command Options > Symbol Table and enter the symbolic names for the
function block FB10 and the data block DB10 in the symbol table.

Then save the symbol table and close the window.

Symbol | Address |Data Type| Comment
Engines FE 10 |[FE 10 |Example of multiple instances

Engine_Data DB 10 FB 10 |Instance data block for FB10 10

Programming the Call in Ladder Logic

Insert a new network at the end of OB1
and add the call for FB10 ("Engines").

STEP 7 Getting Started 10-9
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Complete the call below with the corresponding symbolic names.

Delete the call for FB1 in OB1 (Networks 4 and 5 from Section 5.6 onwards), since
we are now calling FB1 centrally via FB10.

Then save your program and close the block.

"Engine Data"

"Engines"
EN ENO

Preset Speed Reac| "3 Data”.Preset Sp
hed [-eed_Reached

The output signal "Setpoint_Reached" for FB10
("Engines") is passed on to the variable in the
shared data block.

Programming the Call in Statement List

If you are programming in Statement List, select the input area under the new
network and enter the STL instructions below. To do this, use the FB Blocks >
FB10 Engines in the Program Elements catalog.

Delete the call for FB1 in OB1 (Networks 4 and 5 from Section 5.6 onwards), since
we are now calling FB1 centrally via FB10.
Then save your program and close the block.

CATL "Engines" , "Engine Data”
Preset_Speed Reached:="3 Data".Preset Speed Feached

10-10 STEP 7 Getting Started
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Programming the Call in Function Block Diagram

If you are programming in Function Block Diagram, select the input area under the
new network and enter the FBD instructions below. To do this, use the FB Blocks
> FB10 Engines in the Program Elements catalog.

Delete the call for FB1 in OB1 (Networks 4 and 5 from Section 5.6 onwards), since
we are now calling FB1 centrally via FB10.

Then save your program and close the block.

"Engine Data”

"Engines"
Preset_Speed Feac| "3 Data".Preset Sp
—EN hed —eed Reached

E ENO fm

If you require additional engine control programs for your automation task; for example, for
gas engines, hydrogen engines, etc., you can program these as multiple instances in the
same way and call them from FB10.

To do this, declare the additional engines as shown in the variable declaration table of FB10
("Engines") and program the call for FB1 in FB10 (multiple instance in the Program
Elements catalog). You can then define the new symbolic names; for example, for the
switch-on and switch-off procedures in the symbol table.

You can find more information under Help > Contents and —

then under "Calling References Helps" in the topics "The STL,
FBD, or LAD Language Description".
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11 Configuring the Distributed 1/0O

11.1 Configuring the Distributed 1/0 with PROFIBUS DP

Automation systems with conventional configurations have the cable connections
to the sensors and actuators inserted directly into the I/O modules of the central
programmable logic controller. This often means a considerable amount of wiring
is involved.

Using a distributed configuration, you can considerably reduce the amount of
wiring involved by placing the input and output modules close to the sensors and
actuators. You can establish the connection between the programmable logic
controller, the I/O modules, and the field devices using the PROFIBUS DP.

You can find out how to program a conventional configuration in Chapter 6. It
makes no difference whether you create a central configuration or a distributed
configuration. You select the modules to be used from the hardware catalog,
arrange them in the rack, and adapt their properties according to your
requirements.

It would be an advantage when reading this chapter if you have already
familiarized yourself with creating a project and programming a central
configuration (see Section 2.1 and Chapter 6).

Modular slaves:
for example, ET 200 M-IM153

Compact slaves:
for example, I/O modules
ET 200B-16DI / 16DO

PROFIBUS-DP network
between master and
slaves

Direct connection between
CPU and programming
device / PC via MPI

Master device:
for example, CPU 315-2DP

STEP 7 Getting Started
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Creating a New Project

FJSIMATIC Manager
File PLC View DOption: ‘Window Help

0| 22l | =) well

M= E3

Frezs F1 to get Help.

y

< ‘Mew Project’ Wizard... >

STEP 7 Wizard: “New Project”

Bl Which CPU are you using in your project? 24)
CPU:
= CPU-Typ [ Bestalr =]
< CPU3I52DF BES7 315-20F01-00B0)
CPU name:
o nane [cPozsz 0P
MP! address |
a = ﬂ
Preview<
2} 57 P2 Elock Name [ spmbolic Mame [
E-a SIMATIC 300 Station F0B1 Cycle Execution
=l crU3152DP
[=[81] 57 Program(1]
44 Blocks
<Back New> | Make Cancel Heo |

Inserting the PROFIBUS Network

15 GS-DP - £-\Siemens' \STEP7\S7PROJ\GS_DP

Gl =

SIMATIC 30001] MPI(1)

Inzert Mew Object 3

FROFIBUS

7~ T, N
EE=] G o7 =
Sl SIMATIC 300(1) dl
=-[g CFU315-20F SIMATIC 300(1) MPIT)
B33 S7-Programm(1]

(T Source Files
423 Blocks

% GS-DP - C:\Siemens\STEP7\SZPROJ\GS_DP

11-2

The starting point is the SIMATIC
Manager. To make things easier to
follow, close any open projects.

Create a new project.

Select the CPU 315-2DP in the
corresponding dialog box (CPU with
PROFIBUS-DP network).

Now proceed in the same way as for
Section 2.1 and assign the project the
name "GS-DP" (Getting Started —
Distributed I/0).

If you want to create your own
configuration at this point, specify your
CPU now. Note that your CPU must
support distributed 1/Os.

Select the folder GS-DP.

Insert the PROFIBUS network using
the right mouse button in the right half
of the window.

STEP 7 Getting Started
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Configuring the Station

'E"?';ES'DP - CASiemens\STEF7AS7PRONGS_DP

s CPUN4I)
-1 57 Program(1]

" (E Source Fies
" &8 Blocks

Select the folder SIMATIC 300 Station
and double-click Hardware.

The "HW Config" window is opened
(see Section 6.1).

= (1) UR

PS 307 24
CPII3152 DP(1)
OF

The CPU 315-2 DP already appears in
the rack. If necessary, open the

Hardware catalog using the menu

command View > Hardware Catalog

BN
B

or the corresponding button in the

e
=-{E siMaTIC 300
- E-{1 Ps3m0

toolbar.

Drag and drop the power supply
module PS307 2A into slot 1.

[+

=i SMATIC 300
202 sM-300
= DI-300

€] sMaz DIzzoCay

=3 DO-300

<
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SM 322 DO32DC24Y /0. 54

In the same way, insert the I/O
modules DI32xDC24V and
DO32xDC24V/0.5A in slots 4 and 5.

In addition to the CPU which supports the
distributed I/O, you can also place other CPUs in
the same rack (not described here).
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Configuring the DP-Master System

Select the DP master in slot 2.1 and
insert a DP-master system.

DP baster System

Apply the suggested address "1" in the
o . = dialog box displayed. Select
ot st 15 "PROFIBUS(1)" in the "Subnet" field
Tomiscion e 1.5 Mbpe and then apply your settings with OK.
T —
Properties..
Delete

1 PS 307 2k i
2 CPU315-2 DP(1)
OF

You can now move any objects which you
place in the master system by dragging
them with the left mouse button held down.

PROFIBUS1): DP master system (1)

DI32<DC24V
DO32:DC24V/0.58

E’ﬁ'ﬁ' PROFIBLIS-DF Navigate in the Hardware catalog until

you reach the module B-16DI and
insert this module in the master system
(drag the object to the master system
until the cursor changes to a "+" sign;
then drop the object).

& B-1E00

Properties - PROFIBUS Hode B-16DI DP [x] You Ca.n Change the node address Of
olal  Parameters . .
B the module you have inserted in the
Address: E " " n . n
Taramison a1 5 33 Parameters" tab of the "Properties
dialog box.
[ " Confirm the suggested address 1 with
e OK.
el
[ o ) Hbbrechen Hite
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=4 PROFIEUS-DP
N =

=48 PROFIBUS-DP
|

[0k

=oor | i[ﬁ]ﬂ-mm|
E | EPU3i53 BRT) _L =
F
. | | LFROFIBUS{1) D master system (1)
[ Dizzcaa —Y
[q DO32:DC24v /0 54 T\
|| FAOLECY] | FOLAE
e (mo
- S
4= ‘l (4] IM153
ol j—b%
s —— ——
]
G
7
a
9
10

=8¢ PROFIBUS-DP
. =00 ET 200M

L B@ M1
X o
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In the same way, drag and drop the
module B-16DO onto the master
system.

The node address is automatically
adapted in the dialog box. Confirm this
entry with OK.

Drag and drop the interface module
IM153 onto the master system and
confirm the node address again with
OK.

In our example, we are using the default
node addresses. However, you can change
these addresses at any time to meet your
requirements.

Select the ET200M in the network.
The free slots for the ET200M are
displayed in the lower configuration
table.

Select slot 4 here.

The ET200M itself can have additional
I/O modules. Select, for example, the
module DI32xDC24YV for slot 4 and
double-click this module to insert it.

You should always make sure that you are in
the right folder when using the Hardware
catalog. For example, navigate to the
ET200M folder to select modules for the
ET200M.
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11-6

Changing the Node Address

In our example, we do not need to
change the node address. In practice,
however, this is often necessary.

Select the other nodes one after
another and check the input and output
addresses. The "Configuring
Hardware" application has adapted all
the addresses, so there are no double
assignments.

Let us imagine that you want to
change the address of the ET200M:

Select the ET200M and double-click
D032xDC24V/0.4A (slot 4).

Now change the input addresses in the
"Addresses" tab of the "Properties"
dialog box from 6 to 12.

Close the dialog box with OK.

STEP 7 Getting Started
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Station D Finally, save and compile the
distributed 1/0O configuration.

Close the window.
Save and Compile

The menu command Save and Compile means that the
configuration is automatically checked for consistency. If
there are no errors, the system data are generated and can
be downloaded to the programmable controller.

With Save, you can save the configuration even if it
contains errors. However, you cannot then download the
configuration to the programmable controller.

Optional: Configuring Networks

:\Siemens\STEP7AS7PROJAGS_DP

i =

SIMATIC 300 MPI)
Shation

You can also configure the distributed
I/0O using the optional package
"Configuring Networks."

WATIC 300 Station
=-[@ crusis2oP
[=+{Z1] 57 Program(3)
~{@&] Source Files
[£3 Blocks

PROFIBUSH(1)

Double-click the network PROFIBUS
(1) in the SIMATIC Manager.

[ NetPro - [65-DP (Network) - C:\Siem
Edt_lnset PLC View Opions We

i (%) & Sl wi) 5] @l B )t e

5 The "NETPRO" window is opened.

Iw

is opened.

Yo B, You can drag and drop additional
R . DP slaves onto the PROFIBUS DP
C i | from the catalog of network objects.
A
= | | | Double-click any element to configure
it. The "Configuring Hardware" window
I : | . ; Llj

E :

Using the menu commands Station > Consistency Check ("Configuring Hardware"
window) and Network > Consistency Check ("Configuring Networks" window), you can
check the configuration for errors before saving. Any errors are displayed and STEP 7 will
suggest possible solutions.

You can find more information under Help > Contents in the topics
"Configuring the Hardware" and "Configuring the Distributed 1/0."
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Configuring the Distributed 1/0

Congratulations! You have worked through the Getting Started manual and learned the most
important terms, procedures, and functions of STEP 7. Now you can get started on your first
project.

If, while working on future projects, you are looking for specific functions or have forgotten any
of the operating instructions in STEP 7, you can use our comprehensive Help on STEP 7.

If you want to extend your knowledge of STEP 7, there are a number of specialized training
courses available. Your local Siemens representative will be happy to help you.

We wish you lots of success with your projects!

Siemens AG
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Appendix A

Overview of the Sample Projects for the Getting Started Manual

ZEn0l1_02_STEP7__STL_1-10:
The programmed Chapters 1 to 10 including the symbol table in the STL
programming language.

ZEn01 _01_STEP7__STL_1-9:
The programmed Chapters 1 to 9 including the symbol table in the STL
programming language.

ZEn01_06_STEP7__LAD_1-10:
The programmed Chapters 1 to 10 including the symbol table in the LAD
programming language.

ZEn01_05_STEP7__LAD 1-9:
The programmed Chapters 1 to 9 including the symbol table in the LAD
programming language.

ZEn01_04_STEP7__FBD_1-10:
The programmed Chapters 1 to 10 including the symbol table in the FBD
programming language.

ZEn01_03_STEP7__FBD_1-9:
The programmed Chapters 1 to 9 including the symbol table in the FBD
programming language.

ZEn01_07_STEP7__Dist_IO:
The programmed Chapter 11 with the distributed 1/O.
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Index

A
Absolute address .........cccoocveviieiiieniicenee 3-1
Actual values
changing.......ccoooceeeiiiiii e,
AND function
Applying VOtAgEe .......evveeeiiie e 7-3
B
Block call in function block diagram.............. 5-21
Block call in ladder 10giC.........cccoovveeiiiiineenne 5-16
Block call in statement liSt............ccccoeevenennne 5-19
C

Calling the function
Calling the Help
Changing the node address
Configuring hardware......................
Configuring NEtWOrKS..........cccccvierineeeeninneen.
Configuring the central rack
Configuring the Distributed 1/O...................... 11-1
Configuring the Distributed 1/0

with PROFIBUS DP........ccccoovviiiiiiiienens
Configuring the DP-Master System
Configuring the hardware..................ccccvvveee.
CPU, switching ON.........ooviiiiiiiiiiieiee e
Creating a program with function blocks

and data blocks
Creating a Project

Creating function blocks..................
Creating functions ...........cc.cceeeuvveee.
Creating Shared data blocks................c..........
Creating the variable table ................cccvvveee.

D
Data blocks

generating instance data blocks............... 5-14
Data type.....coveeiiiieeeee e 3-3
Debugging with function block diagram.......... 7-6
Debugging with ladder logic ............cccvveeeeenn. 7-6
Debugging with statement list ....................... 7-6

Declaring variables
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Diagnostic Buffer, evaluating ....................... 7-12
Distributed 1/0O, configuring ...........cccceeeeiis 11-1
Downloading the program
to the programmable controller.................. 7-3
DP-Master system, configuring.................... 11-4
E
Establishing an online connection.................. 7-1
Evaluating the Diagnostic Buffer.................. 7-12
F
Function block diagram
block call.........coccveeiiiiiiien

debugging........ccoeeviiiieee e,

programming the timer function
Function block, programming

in function block diagram ................ccec... 5-10
Function block, programming in ladder logic . 5-3
Function block, programming

in statement liSt.........ccooiiiiiieniie, 5-7
Function blocks, creating..........cccccceeeeeiiiinnnes 5-1
Function blocks, opening..........cccccceeeiiiiinnns 5-1

Function, calling
Functions, creating
Functions, opening .........cccccovevveernieeeeiineeens 8-1

H

Hardware, configuring
Help, calling

I
INStallation ..........oooveeeiiiiie e 1-5
Instance data blocks
geNerating.......cccovcvvereeeeeeieeiiiieer e e e ee s 5-14
Introduction t0 STEP 7.....ccoviieiiiiieeiiiiieeee 1-1
L
Ladder logic
block call..........ovvvviiiiiiiiiie 5-16
debugging .....c.coovvieiiii e 7-6
programming the timer function ................. 8-3
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Index

M
Modifying variables ...........cccccovieiiiiiiinnnen. 7-10
Module information, query ..........cccccveeenunee. 7-12
Monitoring variables.............cccccoovviiiiieneeen. 7-10
Multiple instance, programming ................... 10-1
N
Node addresses, changing ...........ccccceeeeenn. 11-6
O
Online connection, establishing ..................... 7-1

Opening function blocks
Opening functionsS............ooooiiieiieiieniiieee.

Opening shared data blocks .................c.cc.... 9-1
Operating Mode, checking
OR fUNCHON ....eiiiiiiic e

P

Procedure using STEP 7 ........ccoovviiivvvieeeeenn, 1-4
Program, downloading to the

programmable controller............ccccccovveenn.
Programming a function (FC).................
Programming a multiple instance...........
Programming a shared data block
Programming FB1 in

function block diagram.............cccccvveeee... 5-10
Programming FB1 in ladder logic................... 5-3
Programming FB1 in statement list................ 5-7
Programming the timer function in

function block diagram ............cccccevviiieinne 8-5
Programming the timer function

in ladder [0giC.......ccveiviieeiiniee e 8-3
Programming the timer function

in statement liSt.........cocceeeiviiiiiniiee e, 8-4
Index-2

Programming, symbolic..........ccccccovvvininnnnnne 3-2
Project structure in the SIMATIC Manager .....2-4
Project structure, navigating
Projects, creating........ccocveeeeeeiiiiiiiieee e

R
Resetting the CPU and switching it to RUN....7-3

S
Shared data block, programming ................... 9-1
Shared data blocks in the symbol table.......... 9-3
Shared data blocks

in the variable declaration table.................. 9-3
Shared data blocks, creating...........cccccooveenn. 9-1
Shared data blocks, opening.........cccccceveeeenn. 9-1

SIMATIC Manager
Project StruCture...........coeevvvvveveeeeeecciieeeen.
SIMATIC Manager, starting................
SIMATIC, further software..................
SR function........ccccevieiiiie
Starting the SIMATIC Manager ..............cee....
Statement list
block call.........cooviiiiiiiiin
debugging.........occoiiieiiie
programming the timer function
Switching the variable table online
Symbol editor ..........ccooveiiieeiieee
Symbol table.....................
Symbolic programming

Vv

Variable table, creating...........ccccceeeevvinnnnnn.n.
Variable Table, switching online
Variable, modifying..........ccccoceeeeeennns .
Variables, monitoring...........cccccceveeeiviivnneen.n.

STEP 7 Getting Started
ABE00171228-01



	Title
	Welcome to STEP 7...
	Contents
	1 Introduction to STEP 7
	1.1 What You Will Learn
	1.2 Combining Hardware and Software
	1.3 Basic Procedure Using STEP 7
	1.4 Installing STEP 7

	2 The SIMATIC Manager
	2.1 Starting the SIMATIC Manager and Creating a Project
	2.2 The Project Structure in the SIMATIC Manager and How to Call the Online Help

	3 Programming with Symbols
	3.1 Absolute Addresses
	3.2 Symbolic Programming

	4 Creating a Program in OB1
	4.1 Opening the LAD/STL/FBD Program Window
	4.2 Programming OB1 in Ladder Logic
	4.3 Programming OB1 in Statement List
	4.4 Programming OB1 in Function Block Diagram

	5 Creating a Program with Function Blocks and Data Blocks
	5.1 Creating and Opening Function Blocks (FB)
	5.2 Programming FB1 in Ladder Logic
	5.3 Programming FB1 in Statement List
	5.4 Programming FB1 in Function Block Diagram
	5.5 Generating Instance Data Blocks and Changing Actual Values
	5.6 Programming a Block Call in Ladder Logic
	5.7 Programming a Block Call in Statement List
	5.8 Programming a Block Call in Function Block Diagram

	6 Configuring the Central Rack
	6.1 Configuring Hardware

	7 Downloading and Debugging the Program
	7.1 Establishing an Online Connection
	7.2 Downloading the Program to the Programmable Controller
	7.3 Testing the Program with Program Status
	7.4 Testing the Program with the Variable Table
	7.5 Evaluating the Diagnostic Buffer

	8 Programming a Function
	8.1 Creating and Opening Functions (FC)
	8.2 Programming Functions
	8.3 Calling the Function in OB1

	9 Programming a Shared Data Block
	9.1 Creating and Opening Shared Data Blocks

	10 Programming a Multiple Instance
	10.1 Creating and Opening a Higher-Level Function Block
	10.2 Programming FB10
	10.3 Generating DB10 and Adapting the Actual Value
	10.4 Calling FB10 in OB1

	11 Configuring the Distributed I/O
	11.1 Configuring the Distributed I/O with PROFIBUS DP

	Appendix A
	Overview of the Sample Projects for the Getting Started Manual

	Index
	A
	B
	C
	D
	E
	F
	H
	I
	L
	M
	N
	O
	P
	R
	S
	V


